Uninstall UGS Platform

Hello All,

I had UGS working on a raspberry Pi and I love it except that the visualizer is not working, and this scares me as I don’t see what the xcarve will do. I can easilly click on the wrong file. Last time I didn’t noticed that the zero point whas at the center of the piece instead of the bottom left corner :scream: I will get back to the pi once this issue is addressed.

So I decided to move up to an old Windows 7 machine with a clean fresh install. I didn’t paid attention and installed a stable built of UGS, which had no import options for the macros. I started adding them one by one and imported the keymaps (macros and keymaps are for the X-Pendant). When I realized that I wasn’t using the nightly built, I downloaded it and ran it to discover it was using the old setups, macros and keymap were still there. I then tried to upload the macros with success, but no way to reload the keymaps. It keeps loading with no success.

I deleted the UGS folder and redownloaded it. And when I run it, all my previous setup are loaded. I see no other way to uninstall UGS, it does not appear in the program list, so uninstalling it thru the control panel is not an option.

Does anyone knows a way to clean the computer from UGS, or at least clear the modifications I made?

Thank you.

Somewhere, there is a UniversalGcodeSender.json file. Delete it. Open UGS again.

On my Windows machine, it was under Users/me/.ugs

1 Like

@NeilFerreri1 Thank you for your reply. Deleting the file resulted in the macro page to be blank so I could reloaded my macro file. But did not solved the keymap issue. My older keymap is still there and I also notices that my UGS layout remained unchanged. There must be another file somewhere.

At least I am sure that my macros are correct. I can still duplicate the keymap and rename it, and then reenter the shortcuts

There’s another folder .ugsplatform. Mine was under AppData/Roaming on my machine. I’d just get rid of all of it.

I deleted both folders and uncompressed a new UGS Platform. Everything was clean like at the first installation. Uploaded the macros without any problem, but still can’t load the keymaps. It keeps loading the Options for Import forever :disappointed_relieved:

I had not have this problem when I first installed the stable buit. And then I installed the nightly built on top of it. Could this be related?

How did you export your keymap?

keymaps are from the machanicalgoose.com website. They worked great on the pi installation. I have redownloaded it several time in case it was corrupted but with the same result

Worked for me, but it was weird.
It did not work from the keymap tab. I’ll see if I can reproduce, so I know exactly what happened.
EDIT: That wasn’t it…trying something else.

This worked:
Tools–>Options–>Import–>Browse for ZIP–>OK
Everything flickers
Close Options window
Open options again --> keymap -->Manage profiles
And then they magically showed up?

Here are the exported keymap files (import through the Manage Profiles menu).
exported-X-Pendant-mm-profile.xml (1.7 KB)
exported-X-Pendant-profile.xml (1.7 KB)

I am stuck at the loading of the file. I duplicated the default profile and added the shortcuts manually