Universal Code Sender (UGS) with Windows 7?

I am very new the CNC stuff and the X-Carve. I have the 1000mm X-Carve & V-Carve Pro. I like V-Carve Pro because of the advantages over Easel. I have Windows 7 on my laptop and use Chrome as a browser. I have tried UGS downloaded the zip file and extracted the files and tried to run, but I can not get it to run or setup. Does anyone have any solution to this or is there another gCode sender that will work?

You will need the latest version of Java installed, Also be sure you are running the “Start-Windows.bat” file not the JAR file.

If the UGS version you have is not working you can try the 2.0 nightly build version

The 1.8 version would not open correctly for me, but the 2.0 version works perfectly.

Thank you Allen.
I have the latest java. I uploaded the 2.0 version and it works, I will try it with V-Carve in the AM.
I do YouTube vids, Randy Richard In The Shop, could I mention your first name in a vid and thank you
for helping, me?

No problem, glad I could help. Lord knows I have received more than my fair share of help here.


Also be sure you are running the “Start-Windows.bat” file not the JAR file.

Allen, I’ve seen this mentioned several times on this forum, but in my case (Windows 7) if I run the .bat file I get errors. If I double click the .jar file it runs fine.

What do the flags in the .bat file do?

I have the UGS up and running. But will not connect to the Arduino Ono. The -xcarve works fine through Easel.
Shows connected to COM5. UGS does not list COM5 in the serial port list. I am not sure what is up?
Thank you Allen.

Just a thought. You cannot run Easel and UGS at the same time.

I will make sure of that and try it, I may of had Easel open. Thank you Larry.

You may just need to reboot and then start UGS fresh,

I just put the jar file on my desktop and click on it when i want to open ugs. I have win7

I had lots of issue when i ran v1.08 (some not fault of ugs) but since switching to 2.0 ugs and upgrading to a trim router, all of my cuts have been problem free. Cant say which was causing the problems (losing steps, not cutting what its supposed to, going haywire mid project, etc) but i changed those two things and its like a new machine

I have an older Dell NB Win7 32bit, to be my dedicated CNC PC. But every time I try to load UGS, it kicks an error flag stating this version of Windows is not compatible. UGS does not have a matrix of Win# to UGS Version compatibility. So frustrating. But at least I got GRBL Candle working on Win7. Still cant get Easel to accept my 3018Pro and looks like Easel cannot export/save to .nc So so frustrating.

What format does it export…I thought it was.nc
Just change the extension otherwise. It’s just a text file.

I have ugs stable classic version on my laptop with system 7. It works fine. I’d investigate further.

1 Like