Universal Gcode Sender for linux

Does anyone have a tutorial on running Univeral Gcode Sender on linux? I’ve been trying to run the .jar but I can’t seem to get it working.

I’ve got it running now dont worry

Any particular references that might be useful for the future? Or should I delete this thread?

Feel free to delete, turns out I didn’t have java installed correctly

Jamie it would be intersting to know what was wrong with your java and what the solution was.

I attempted to upgrade from win 7 to 10 but reversed it when I discovered that VGA graphic were not supported yet and my second screen would not run. UGS has not started for me since the reversal.

I have tried to reinstall java to no avail. I have tried deleting all of java and UGS, re-downloading both and reinstalling , No joy. Currently I am thinking about looking for something else.

And before someone says it, I dont really care for chillipeppr, Too many options/buttons/gadgets, It may be a capable program but it’s web dependent and frankly, I find it confusing.

You could try PicSender. It has a very simple UI and has been tested to 10,000,000 lines of gcode which is very reliable. We are about to release a new version in the next day or two that has a Z retract settable distance setting so your spindle and bit will retract out of the material when canceling a job before it travels back to your X&Y zero starting place. It has been extensively tested in Win XP through to Win 10.


The issue with its isn’t any installation big. It’s just the face that UGS sends the WRONG g code to the machine for tasks like resetting zero. So he machine is unable to do it without me typing it in the console

@JamiePhillips am I the only one who runs in to the problem where UGS destroys my freaking wasteboard if I ever hit return to zero? It’s ridiculous! I have pretty much given up on UGS and am ready to purchase a program that won’t do what it wants. Its so frustrating! My wasteboard almost caught on fire last night because It was trying to bury itself inside the aluminum extrusion at the front of the X carve.

Needless to say, after procrastinating even though I’ve already ordered the E-stop, I am now installing it asap!

If I were you I would dump Arduino/GRBL and UGS and move up to better electronics and software to run it. Mach3 and stepper drivers that will take 48VDC or Free LinuxCNC with stepper drivers that will take 48 VDC
I would also dump Easel and go with Fusion 360 or some of the other CAD and CAM programs.

Hope this helps


Oh my god yes that was the worse thing. I isnatalled the new UGS though, damn! I’ve had 0 issues since :smiley: homing works too :wink:

Wow! I posted on this seemingly so looooong ago.

I did get UGS working, I ended up downloading the nightly build 2.0 and got things going again.

being the nightly build I did find a few quirks, I still need to hit pause and resume to finish and shut UGS down after a run, no bigggie. But, UGS then sets my increments to metric and toggling from mm to inces wont change it. I need to go into the command line and use a g20 code. then it will change.

But, at least it functions reliably!

1 Like

Unless you’ve updated your grbl, that’s most likely an issue with the version of grbl .9i that you’re on. There was something about it having a problem with the “M” command used to finish a job. Once I updated to a later version of .9i the problem went away.

I have that problem too. The ONLY real issue I have now is GRBL resettings its position after a job. Meaning I can’t run 2 files after eachother for a tool change without manually editing a return to zero in the G code before it resets itself.