Universsal gcode sender

I always have NO Serial Port Found

The x-carve is not plugged into the laptop computer…

And I do not have have Internet service in the wood shop…

I get that message even when its plugged in.
It doesn’t happen all the time, but when it does, I have to unplug the USB, wait a few seconds,then plug it in again, then restart UGS.
Not meaning to hijack your thread, but just letting you know what I need to do.
I’m looking around for another program.

Have you investigated another program?
If you did, what have you found and or recommend?

1 Like

I have been using bCNC basically without problems. I did have it send a funky code today which caused it to halt. No damage to the piece, and I think it had to do with a hiccup when I was adjusting the feed speed over-ride.

The only funky thing going on with it at the moment is that the preview is displaying the code in mm when the file is in inches. The cut is happening in inches, and the “bit pointer” on the screen is moving in inches, so I haven’t messed with it.

I do not use Easel because I do not have an internet connection in my shop along with other (“cloud”) reasons.
I use Vectric desktop for all my design ((all) I’ve only been doing this for 4 months)) and use the post processor that Phil shared.

I downloaded picsender, but for some reason I simply cannot get it to work.
Once I open it up, it just sits there, doesn’t matter which button I click, nothing happens.
I’m not looking for a freebie program.
I just want something that works without annoying problems.

But, I think we’re hijacking someone else’s thread which is certainly not my intension.
I will gladly start another thread.

I think Phil and I share some common problems.

1 Like

I’ve been having trouble with Picsender lately. Some kind of communication error with Grbl.(Can’t remember the error exactly). It has stopped in the middle of carves a bunch of times. When I run the same program in UGS it does fine. Funny thing is, I switched from UGS to Picsender because I was having problems with UGS.
I thought the problem might go away when I got a powered usb hub but no dice.

Ok Bob…explain to me how the Arduino Board s going to set-up a Serial Port on the computer ???

Without a Serial Port the computer will not even talk to the Arduino…

Sounds Simple enough…just Not very Logical…

Do you have the Arduino device driver installed on your computer?


Do not load any sketch into the Arduino or you will overwrite the grbl code which will require you to reload grbl before you can use the X-carve.

If you have the X-controller then you need the FTDI USB driver.

1 Like

Yes LarryM, I do have all the drivers I can find installed, and yes I do have the Arduino Software installed.

But unfortunately I am still not able to get my Laptop to find a serial port.

I just wonder if my HP laptop is just NOT the type of computer that is necessary to run the Adruino card.
The Computer is running windows 7 Home edition.

Or maybe I need a NEW arduino Card… I sure can not get any place with my X-Carve, looks pretty just sitting there, by the way, with 115 volts plugged into the control box and the USG cable plugged into the computer,
No serial Port Found still comes up, But the router Motor runs just fine, and the arduino board lights up.

No I have not tried that, but at this stage I feel it would well be worth the effort, and thank you Robert for your suggestion to try it out.

Dennis, if you open the arduino IDE then under tools you select the correct board when that is done you can go to ports and you should have an address to a virtual port that was created when you plug in your arduino. If you don’t I think it is a driver issue.

Good Luck