Inventables Community Forum

Unusable slow easel

Any body else having problems with easel being unusable slow.

Can some one try out this file
http://easel.inventables.com/projects/6YUUdNyPiEi0apCOyns9CQ

Not sure if ive done something wrong or if its my hardware but Its unresponsive.

Could someone test out editing the holes in this project to cut inside rather than outside?

Ive tried in 2 browsers and disabled the 3d view on both but its still an issue

Worked fine for me…maybe a little slow, but not that bad. I had the 3d view open.

I selected a few of the cutouts, changed to inside the line, all worked fine. I rarely use easel, so if it is slow, not sure I would notice.

@ErikJenkins thanks for taking a look.

What software you using to generate your gcode?

I use V-Carve to generate my G-Code and Universal G-Code Sender(Nightly Build) to send to the X-Carve.

It looks like the performance problem is caused by the large number of tabs in this project. When we launched the interactive tabs feature, we took on some overhead for previewing tabs and making them editable. It looks like there are many circles in this project that are set up to use tabs (which is the default for an outline shape that goes all the way through).

When I select all (cmd/ctrl+A) and uncheck “Use Tabs,” Easel’s able to respond normally. You might then be able to selectively turn tabs back on just for the shapes that need them.

We’re going to look into improving the responsiveness with this many tabs. It’s not acceptable to us that this is happening.

Jeff

1 Like

Thanks @JeffTalbot that helped me get it back to a usable state.

How do I change the thickness of the material in the editor screen in order to make use of the tabs

Change the thickness of your material by clicking on the “Material” menu and changing the “Z” value:

Thanks man. your a life saver!

I noticed this yesterday when importing lots of small designs with outlines. Performance was so bad I was getting the script wait or kill dialog.

As the design was an SVG from Inkscape I simply went back to Inkscape and recoloured everything 90% grey before importing into Easel. This then prevented the tabs from being generated and performance was much better. I could then fake the depths for a full cut if necessary but I’m lasering so not important.

As my designs are fills within outlines a blanket Ctrl + A doesn’t allow the option of selecting everything then turning off tabs.

It’s not really a problem overall and I’d still rather have the new tabs over the old. But yes performance is affected but I know Jeff will want a fix :smile:

Cheers

Ian

Hi Jeff, sorry to write on a too old post, but it seems that this issue still happens, is there a way to improve the work with tabs? all my work need them and setting them one by one is such a time comsuming job that sometimes i quit to do it.