Usb B connection help

Hello all just wondering if anyone had tips or a product that could help stiffen or hold this usb B in place so it doesnt wiggle as much when its running and make easel think the projects done when its not.everynow and then it will interrupt my runs wish it was a normal usb kinda poor placement in my opinion thanks.

It is a “normal” USB. Are you sure that you tightened the bulkhead flush against the front plate? It looks like there’s a gap between the front bulkhead and the connector.

Mine inserts fully and I believe it has a little bit of a “click” to secure it.

Right i ment like a usb A…i will give this a try thanks

I tried unplugging it an plugging it back in an putting a little more force but i didnr hear any clicking noise an there is still a little bit of play

For now ill just try this.


Had similar problems with random disconnects during a carve, tried every suggestion and still had problems. Found that replacing the USB socket panel connector with my own seemed to fix it for good. I had a 8" mini usb to full size and swapped it out. Doesn’t stick out so far and it works,so I’m good with that…

I just messing with my Xcontroller tonight. Check your USB cable for these on the sides:

Those engage and make a clicking noise:

I am not near my controller to get a picture, however I used these items… right angle connector and zip tie mount.

Thanks guys ill give that a try as well

Ya myn defenitly does not connect like that or make that noise more like a thud but snug

I remember when assembling that the bulkhead took quite a bit of screwing to get flush on the inside of the box.

My Xcontroller is underneath my machine so the cable is very stable for my setup.

i had another disconnect half way thru again do u have picture of the inside or your x controller so i can see how its connected and everything used? thankyou

Is it easel then?

Guess im just a little bit frustrated redoing this same piece 3 times now wasting time and money.the most important part of the process and this many problems shouldnt happen.

I had a very similar problem that took forever to figure out and I only solved it by accident! I tried a few different cables and my connection would fail for the weirdest reasons. Just turning a fluorescent light on or off could cause it. Eventually the laptop I was using died and since replacing that I have had no problem. I since found out that some USB receivers in computers are not as good as others. I’m just very lucky the laptop died or I would still have the problem. I hope you don’t have to replace your computer but it may be worth asking a tech if the USB receiver can be checked! I’m not a tech so I don’t know if that can even be done!
Hope this helps!!

Thanks for your reply im gunna troubleshoot more tommorrow

I shut off one of the usb power saving modes so ill give that a try thanks again for ideas

Inventables had a problem with the small internal usb cable that goes from the bulkhead to the circuit board inside the controller, sorted now. However, I took my internal cable out and connected the long cable direct to the circuit board inside, passing the cable through the usb b hole left vacant in the bulkhead. Never had a disconnect since.
Good luck

Im gunna give your idea a shot luckily i had a spare cord that fits right in the x controller and goes right into my computer

Let us know how that works.
I have had mt machine for almost 11 months and never had a disconnect until Friday night 11/17/2017.
At that time I had multiple disconnects.
Maybe I should call it something else as the router and dust collection did not shut off and both are controlled by easel auto spindle control.
First failure happened after carve completed and I was entering commands in the advanced panel.
Re-connection required turning the X controller off and back on. After connection was established then m3 command would not activate the IOT relay. At first I thought the relay had failed but testing voltage out of the controller there was no voltage being sent to the relay.
I re-routed power for the router and dust collection back for manual control. After homing the machine I started my next carve. When I told it to turn on the spindle I heard the relay click. Testing showed auto spindle control was working again so I arranged wiring again. Then I had a lost connection again.
Same thing m3 commands would not work after reconnected and homing. But when starting a carve it worked. As long as connection was not lost the m3 command would work after carve was finished.
I think there was more to my problem than USB connection. But what is puzzling is m3 command not working. Also as I understand it after a carve is started an internet connection is not required but one of my issues happened mid-carve. My wifi signal is strong in my garage so I don’t think that is the issue. My USB connection is tight as well.