Inventables Community Forum

USB Connection Error

Laptop will not connect to XCarve using Easel Pro driver(s). Post-November 2021 XCarve with upgrade bundle. Windows 11 through HP laptop. Keep getting error message that states device failed last time it was used. Followed all instructions, including installing normal easel and FTDI drivers. Uninstalled, re-installed, uninstalled, reinstalled about 50 times. All hardware components in control box checked out okay. good internet signal. It was actually working the first time I started it up… i was able to jog the x, y, and z axis, click yes to the startup buttons, had trouble when I got to the homing switches… stopped the machine… hasn’t connected since. please help… i’m about to send it back.

Also, device manager: USB controllers: “unknown USB device; device descriptor request failed”

In Device manager, anything showing in PORTS? IF it shows under ports but as 1-3 then i suggest forcing to to change to a number 4 or up, you can do this in the advanced properties of the port… if its even showing there,

Also after all of the driver installs, youll want to restart , and i like to do this with the USB plugged in, because windows will see the USB and try to connect and will update missing drivers (except the easel one, so really just the FTDI and any others effecting USB connectivity)

I used a different laptop and it worked until the homing step, where the spindle traveled to the bottom left corner and rattled badly, so i hit the stop button. When i adjusted the switches and started the machine setup sequence again, it gave me the ‘last USB device you connected malfunctioned’ message.

Make sure you download and extract the two software pieces of Easel.

1 Like

I’ve tried everything. Double checked all connections, tried using a different laptop and a different usb cable. Nothing will work. It connects the first time I plug it in every day but then fails shortly after and then gives me an error message.

make sure the emergency stop button is pulled up too.

Figured it out. Usb Masthead had a short. Sending me a new one. I plugged the usb from laptop directly into circuit board and it worked.

1 Like

It was at this point that I realized same person as on FB.

I’m sorry for repeating the same things to check in 2 places :man_facepalming:

Glad you got it figured out!

Thanks for the help!

1 Like