Use Last XY Feature NOT Working

I’m just wondering if any users have recently experienced issues using the “Use Last XY” feature when running a second toolpath on the same job, or doing repetitive jobs on multiple workpieces.

I always Home my machine at the beginning of each session. I then use a TriQuetra touchplate to set the initial XYZ zero for the first job or toolpath. I also use a lower-left corner bump stop or alignment pins (depending on the job and material). Then when I change bits to run a second toolpath, or run a second job, I run the probe process to reset Z-zero and use the “Use Last XY” and proceed to carve. It has always worked fine…until recently.

Now, every time I try to use this workflow, regardless of whether I’m carving a design created in Easel, or importing a G-code file from V-Carve Desktop, instead of starting the carve at the expected lower-left area, the machine slowly travels on a diagonal path from the lower-left to the upper-right. Once it gets past the midway point and well past the boundaries of the material being carved, I hit the Emergency Stop button…not knowing where the machine would end up going.

After 4 days of trying to contact Inventables Support, I finally got through and their proposed solution was to re-home the machine each time a bit change is made or a second repetitive job is run in order for the “Use Last XY” feature to function properly. I tried it this afternoon (seems a little Mickey Mouse to me) and it didn’t resolve the issue. And instead of travelling on a diagonal path from lower-left to upper-right, the machine started moving up the Y-axis, then a small movement to the right, and the continued to travel up the Y-axis, and so on until I lost my nerve and hit Emergency Stop.

I just reviewed a number of posts on the subject and both Neil Ferreri and Haldor Looningdal have clearly stated on several occasions that the XY positions are retained in memory through power down and power up cycles until they are changed, and providing the machine is homed before a work session, the Use Last XY feature should work as intended.

This afternoon, I played around with a couple of “small square pocket” designs in both Easel and imported G-code from V-Carve desktop. As long as I set my XYZ zero each time, either by jogging into position or with the TriQuetra touch plate, they carved perfectly. As soon as I tried to run the job using the Z-probe and Use Last XY feature, the problem persisted. I would appreciate any ideas on trouble-shooting or a possible solution.

Can you zero with Easel instead of triquetra and see if the behavior persists?

Hi Neil

Yes I have done that, and the problem still exists!!! The use of the TriQuetra touchplate was the first thing I tried to troubleshoot. I forgot to mention in my original post that since I last used this feature, there is now a “warning message” in Easel regarding the inclusion or exclusion of a header, and I’ve also tried running the jobs both ways. Not being a G-code guru, about the only difference I could tell was including the header/footer returned the bit to the XY (safe) Z zero position.

What if you don’t probe at all? Set zero manually for XY & Z.

I’ve done that as well. I’ll have to check my notes to confirm, but I think that was a failure as well. But I’ll try that again tomorrow.

As I said in my original post, as long as I set XYZ each time, either by manual jogging into position or with the touchplate, the jobs run fine. And that’s what I’ll have to do until I can get this resolved. It’s just I can’t understand how it worked perfectly all through last Winter’s carving season, and the first time I go to use it this season, I’ve had nothing but grief!!!

I appreciate your help, and by the way, I stole your idea of alignment pins from one or your previous posts.

Weird. So, the only way zero could change is if it is explicitly changed.
I don’t use Easel, but I’ll look into this…

EDIT: I tested a bunch of different scenarios, and the work coordinate system offsets all behaved as expected.
Another hunch… @RobertNichols, Can you post your $$ Grbl settings?

Here you go…

  • ok
  • $132=100.000
  • $131=510.000
  • $130=510.000
  • $122=50.000
  • $121=500.000
  • $120=500.000
  • $112=500.000
  • $111=8000.000
  • $110=8000.000
  • $102=188.843
  • $101=39.870
  • $100=39.883
  • $32=0
  • $31=0
  • $30=1
  • $27=1.000
  • $26=250
  • $25=750.000
  • $24=25.000
  • $23=3
  • $22=1
  • $21=0
  • $20=0
  • $13=0
  • $12=0.002
  • $11=0.020
  • $10=115
  • $6=0
  • $5=0
  • $4=0
  • $3=4
  • $2=0
  • $1=255
  • $0=10

AND to clarify something in my original post, and after reviewing my notes…when I re-homed the machine after a successful first carve (only using Easel), when I ran the second job (again, only using Easel), probing for Z-zero and using Last XY, this carve was also successful.
It was when I imported a V-Carve Desktop G-code file (saved using the Easel post procerssor) and re-homing the machine, probing for Z-zero and using Last XY, that I experienced a failure and had to abort.

And can use advise what command to enter to return the machine to XY zero. I was thinking of jogging the machine to the center, and then issuing this command to see if in fact the XY zero co-ordinates have been retained and the machine travels to XY zero.

Thanks for all you help, and Merry Christmas!!!

So maybe a Vcarve post processor thing?
Can you share a gcode fine exported from Vcarve?

This is just a small 0.125 deep pocket…

Hope this works…

Small Stair (Rev) - 2F-SC x (2.8 KB)