Vcarve Desktop + UGS + X-Carve - Cutting incorrectly half wayinto job

Good day one and all,

Please help. I recently purchased the VCarve Desktop and Downloaded UGS v1.0.9. (first downloaded the new UGS v2.0 but it does not want to open). I created 3x simple tool paths to cut a dome (tool paths consisted of roughing tool path, a finishing tool path and a cut out tool path) and saved the tool paths. All works 100% on UGS - started by loading the roughing tool path in the UGS and running the tool path.

Now the problem I am experiencing is as follows: The X-carve starts cutting perfectly, cutting at 1mm depth as specified. It completes each depth but starts giving problems between 4mm and 6mm. What basically happens is that the x-carve runs as per tool path specified and then just starts cutting randomly any where it likes at any depth possible. I have tried rewriting the tool paths and it has done it now 4 times, once at 4mm, once at 6mm, once at the beginning of 5mm and the last time at the end of 6mm.

It is suppose to cut x raster at 1mm depth with the dome in the center. I am using a 6mm end mill cutter. The total size of the cutting area is 254mm x 254mm. I am cutting on a x-carve 500mm. The material being used is mdf 16mm. The total high of the dome will be 12mm. I set the zero point every single time before cutting and it cuts perfectly and then just looses its cutting point. It does not ram against any point on the job or against any rails that could cause it to loose its positioning. I do not allow my Laptop to go into sleep mode at all and all screen savers and back ground programs are disabled.

Please can any one advice what could be the problem?

Kind Regards

Are you running any dust collection? I ask because it creates static electricity which can find its way into your electronics and cause this sort of behavior , especially with the random nature of its appearance. Grounding the DC hose back to the system ground or even better to the building ground would mitigate the static buildup . I have mine grounded to the plate screw on a nearby power outlet. If you go this route be sure your outlet box is properly wired to ground or this will not work for you

It looks more like a mechanical issue.
Not ruling out the Static buildup of course.
Check that you have everything mechanically correct and that the pots are set correctly on the GShield.
I have had many issues with depth and it was the Arduino setup.
You can try to run the setup that easel provides and see if it resets things. (I had a poor depths on Z and then after using UGS to try to calibrate the Z went and started grinding and doing the setup helped.)
Also check the belts and pulleys as they can slip or the little slugs that hold on the pulley tend to get lose. I had one fall out till I used some locktite on it.
Check the V wheels if they are too loose or too tight you can get skipping too.
To reduce static you just have to make sure your X carve chassis is grounded to the same ground your electronics are and that will protect your boards. If you use shielded cables too will help.
I do not have those sorts of issues myself but if I did thats what I would do.
There is a video on calibration you should check to see if you need to run any calibration.
Hopefully you get it working properly soon.

One thing I forgot to ask.
Does the job after its finished return to the exact home position or is it off?
If its off then its definitely mechanical
Try running a job in the air and see.

1 Like

Hi guys,

My apologies for the long delay in responding. I have not had a lot of time to work with the X- carve since your last responses. First of all, I would like to take this opportunity to thank all of you for the prompt responses to this dilemma that I am facing. So this is what I have done so far:

I am not running a dust collection system as yet, but keep all clean and dust free as far as possible by using an air hose to blow all dust away as much as possible.

I have gone as far as to purchase a brand new pc and re-installing everything, including the Arduino setup, setting up all that is required from Easel, and so forth.

I have checked and rechecked all pulleys and belts and made sure they are all tight and correctly connected.

I have checked the V wheels and they are not to loose and not to tight.

I have grounded all axis, the y, the x and the z axis.

I have checked the calibration video and followed all instructions given.

After doing all of this, I was able to cut a single 3D stl file perfectly, to my delight but this was short lived. It soon started with the same problem again. So, I restarted checking everything, and trying again, but no luck so far. I even tried running the program about 20mm above the job and surprise surprise it ran perfectly without a single glitch (if only I was trying to create a master piece for Casper the friendly ghost, ha ha ha - sorry guys, a bit of humor is needed as I am completely stressed out about this problem). So I thought, yes, I got something right and immediately returned to zero on UGS, reset my 0 level on the z axis on top of the job, hit send and BAM. All hell brakes loose. The y axis grinds and gets stuck and completely go high wire. It almost seems like the y-axis are getting stuck or slipping (even though all pulleys and gears was checked) and that is the point were I can write of the job and restart doing everything. When this happens, I usually hit cancel on the UGS but it takes the program up to a minute to stop completely. Once stopped, if I do hit the return to zero button it does not return to zero exactly as the y-axis is usually then between 10mm and 50mm of point and requires complete resetting.

I hope all of this makes sense and I am truly desperate and will really appreciate any and all help that I could get.The problem only occurs when you are physical trying to make the cut and not when running the same program above the job.

Thank you so much in advance for any and all help that you could forward my way.

Kind Regards

Here is some information that might help:

Sounds like something is slipping. The steppers most likely.
If you can do an air job then its defiantly mechanical