Vcarve roughing pass issue

Wow that roughing pass tool path looks really busy, lots of red move lines all over the place.

I don’t know why it would cut down the just the sun like that…
So these are multiple STL files you combined into a singe one for import?

My guess is that there is some kind of flaw or artifact in the merged STL file that is choking VCarve?

Lots of home made stl files that I get from sties like thingverse are screwed up in some way. Open holes, inverted faces (inside out), etc. For the most part VCarve ignores these errors or automatically corrects them on import.

I would try opening the stl file in a error checking app and see if there are problems. (there may be something up with the original sun file)
I use NetFabb Basic (free) to do this. There is a web based version you can try:

FYI: One trick I use to try to keep some of tool moves to a minimum on 3D carves is to create a custom outline. I have found that if you trace a 3d object, the offset that path you have a larger curve you can manually smooth out. So that it will do the whole object in a single continuous path.
(I will try to make up some example pics to illustrate this better)

1 Like

Here is more detail on the path outline thing:

Here you can see the bit lifts and cuts each fin section separately.
I don’t like this because I can get little seam lines where the 2 different carve areas meet.

So I trace a loose shape around the 3D carve so that there are no “insets” that would cause the tool path to be broken up. My free hand skills are poor so I usual do path trace of the object and offset that.

Then I do a “Fit curve” to reduce the number of points.

Then I delete and move points until I get a smoothed outline.

You can see with this smoothed outline it now does the tool path as one continuous path (one red start, one red stop). Yes there is extra area being carved away but I find it is worth a little extra time for the smoother result.

I keep looking at the number of moves on the roughing path, are you using a z level strategy instead of a Raster?
If you are using Z Level try the 3D raster and see what happens with the sun.

I have only tried the z level a few time and have not really liked it. I seems to be a faster for some projects but doesn’t clear away as much material.

This one?
3D Raster - Along X
(FYI: I always do “along X” to minimize movement on the Y axis which seems to be the most problematic axis on my machine.)

1 Like

If you throw a big rectangle around the whole project and use that as the only boundary does it still have all those red moves? It should only have the 2. (2 for each layer but there should all be in the same place, right on top of each other.)

If it still has a lot of extra red moves all over I am guessing that is a symptom of the software erroring on the stl file. And where they are may give a hint at to which part is causing the problem.
Though my be is the sun object. Where did you source the file?
If it is free (thingvers?) I will try grabbing a copy and seeing if there is any weirdness in it.

@PhilJohnson, I’m surprised that you are asking for help. You are the forums version of Mr. Wizard. If you don’t know an answer, I don’t know who would!

1 Like

Ok what you are describing is the “Z Level - Raster X” strategy.
It cuts out a “pool” for each level, much like a layerd topography map.

3D Raster - Along X, will move side to side across the whole layer, moving up and down as it goes, clearing everything at once (no “pools”)

(The names are way to similar to no be confusing :frowning: )

I recommend setting up 2 rouging operations, once for each strategy, and running the animations so you can see what I am talking about.

Here are some pictures to help illustrate:

Z Depth Path:
(see all those red move lines)

Z Depth Preview:

3D Raster Path:
(only 2 red moves, - actual 2 for each layer but there are all in the same place)

3D Raster preview:

Personally I prefer the 3D raster strategy. I find that it clears away more material, and lots of red moves seems to add a lot to my cut times. (I could probably tweak my settings to minimize this)

1 Like

interesting. I have never ran into this issue.
I use Vcarve pro

1 Like

As the 3D carving wizard that you are, if you upgrade, then get Aspire. It is designed to do 3D modeling.

1 Like

Same thing happened twice on my Parrot panel carve. First erased Parrot’s head, second time calculated another toolpath, this time skipped about half and inch line accross on detail carve. I had to cut the image from little down from defect beginning and carve again. (You may notice if you close look)
Of course customer didn’t accept. What I did is, on modeling raised model height 0.02" and did 5 hours carving again. Fixed it.
I believe Vcarve mistake. I go over vectric forum and found similar problem, vectric support suggesting to play toolpath optimization for this toolpath mistakes. Like unchecking optimize button, start from bottom to up ETC.
Easy to say for them. They don’t think about time and material waste.

1 Like

I think you can play with the bit step over settings to speed it up. It seems to use a smaller step over on the 3d roughing and I have gone in and edited the tool to take larger step over during these cuts. still a little slower…but speeds it up more than what I will call the default is. That is what it looked like to me…but I don’t use it too often…

Yeah, it is longer, mainly because there are a LOT more small Z moves, so you are moving more at your plunge rate. But it also clears away significantly more material, Which means less load on your 3D pass so you may be able to cut faster there. Which I where I wound up making up the extra time.

I mostly use Z level for bulk clearing of material with a larger bit on really big prints. I then follow it up with a second rouging operation using a smaller bit. But I enter that bit’s cut depth to match the material thickness, so that it does a rouging operation in a single layer. As it is just cutting what the Z depth pass left behind.

I keep playing around with settings and strategies to try to balance speed and quality. :confused:
It been a learning process. But that is half the fun for me. :slight_smile:

With the old gantry I would get weird ripples and issues from the bit deflecting under load long before it would miss steps. :frowning:
I found that if I did a really thin finishing past I could dramatically increase the cut speed without the problems.
With my new upgraded gantry this is not as much of an issue. But I have been sticking with the raster roughing mostly out of habit. I haven’t really played with it sense the upgrade. I think I need to do so, because halving the roughing time would be nice for my larger projects.

On a side note:
I found that with red oak if I do a really thin finishing pass I don’t get the little fuzzies of wood left behind. So doing a 3D Raster Roughing with the finishing bit first (larger step over, max cut depth to go as a single layer) is faster than doing the full finishing pass twice to clear away the fuzzies. :slight_smile:

1 Like

You are correct the speed has nothing to do with the software. Each toolpath operation is calculated independently.

I was referring to the machines mechanical limitations when running that toolpath. And the adjustments I made to speed and depth of cut settings, in an attempt to overcome it.

1 Like

@PhilJohnson I was wondering if you ever solved the issues with your Vcarve 3d Rough Pass cutting off the tops of your vectors? I’m having a similar issue where I used a 3d background and have text above it. The 3d Finishing pass recognized the text correctly but the Rough Z-Level chops it completely off, where 3d Raster leaves the text alone.


I believe I used Hobo, but I’m not near that system at the moment. I can make an STL of the word but I’m using Vcarve Desktop, are you one Desktop or Pro? Being on desktop (or Pro I found out) I can only import a single STL at a time. I could externally combing the text but I’m wondering why the Roughing Z Level pass insists on ignoring the Text in the program and just roughing the 3d stl. The 3d finishing pass recognizes the text and creates the pass around text but not the roughing Z Level.
I actually discovered it by accident. I forgot to even run a roughing pass and ran the entire job as a finish pass. Fortunately it only took 36 minutes with a .125 1mm Tapered ball nose at 80ipm. Vcarve estimated 55 minutes. Win! I’m just trying to figure this out so maybe I can save a little more time on a future project.