What did i fry?

I have a JTech 2.8, I think that I might have hooked up my laser out put H3 in to the laser input H4 and vice versa while the mode selector switch was on the CW mode. I’m assuming this pushed power down to my X controller. when I plugged it in backwards the Z started fritzing (if that’s a thing… didn’t go up didn’t go down just back and forth)

Once I figure this problem out I will ask about the problem that lead me to hook the input and out put up backwards.

When I hook up to USG it will show me connected but when i try to jog the machine it gives me an error “GBRL has not finished booting”. Easel does nothing, machine set up quits at hook up usb and turn machine on.

After researching the has not finished booting message I tried flashing (https://inventables.desk.com/customer/portal/articles/2058884-how-do-i-wipe-and-re-flash-grbl-to-my-arduino-?b_id=9563) i had 1.0c and tried to put that on and get an error on that too **not in sync and programmer is not responding. looking at the bottom right of the arduino ide it show arduino/genuine uno on com 3 when it gets to the final error the machine twitches but no luck flashing.

might as well throw it out there that i have about a months worth of time with the machine and about 2 weeks with the laser so i know little about what im doing, i have read through the forums on this site and others as well but am lost on this one… and the one that got me to this point but we will work on one thing at a time.

so do i need to buy a new ??? or is their hope for me?

Check to make sure that your baud rate is set to 115200 when trying to access the uno with any program and when you are trying to flash grbl into the Arduino/X-controller.

Was set at 115200. Don’t think I was given an option when flashing unless I missed something.

Open the X-controller and look for burn marks on the processor PCB and the ICs on that board. Look for ICs that may have a melted spot on them.

Check your ribbon cables as well. Those may be shorting out and causing an overall +5V rail issue. In fact, you can remove all ribbons cables and the Xcontroller should still function so I would do that as a first step.

Make sure you have +24V output on the power supply as well.

Would the reversal of power reach the ribbons? I have the laser hooked up into to the Spindle PMW and GND.

I’m at work now but plan on tearing down the X-Controller tonight when I get home.

Might be worth mentioning but the laser when hooked up correctly still turns on when in CW mode.

The PWM signal goes straight to the Atmega328P. If you burned out that port then it could take the whole chip with it. Cables between the port and the external terminal could also be compromised.

The laser output is a constant current source. It can output a large current even in a short circuit situation. That will stress any component down the line that cannot accommodate the amount of current flowing.

The SPINDLE PWM signal goes from the Power Interface board (the thing screwed onto the power supply outputs) through a ribbon cable to the main control board and then to the ATmega328P.


As Larry indicated, anything on that chain may be fried.

The Xcontroller doesn’t need that ribbon connected in order to function, you just can’t home or probe while it’s disconnected.

working backwards from the source of wrongly input power how would I test the power interface board, the ribbon I can do, then the ATMega.

The x controller powers up, stepper motors engage and fan comes, com port connects but no control through USG which leads me to a not so educated guess that it’s the ATMega.

Guess I’ll be color coding the terminals for future use

fried the control board. John worked with me to get a new one, awesome customer service. color coded the in and out put so I don’t do that again.