What does easel utilize to compute toolpaths?

Wow! This EXACT same thing has been happening to me also. It just started timing out within the last week or so. Extremely frustrating!

I never had this issue prior to the last week or so. I tried sending on multiple computers - nothing worked. I am to the point where I am looking for different software. Artcam or Fusion.

I split my file into 2 separate files.just as a “band-aid” for the time being but I know that I will not be able to do this with some future files. It worked some what better but is definitely not practical in the long run.

I did notice that the “Beta Tool-path” feature under Machine > Advanced is not an option anymore within Easel so I am wondering if that was implemented and is the cause.

My jobs have just been large signs so I can’t image what an extremely detailed file would do.

Sure hope something is figured out soon.

1 Like

not every time but some times when this has happened i will switch between firefox and chrome browsers and it to make it work.

1 Like

I noticed the other day when I tried to copy a single pass line, I was cutting with a vbit on Phil’s dust boot design. I created the line for 1 of the parts and then figured I would copy and paste it for the other 3. The second was easy it was just a copy and move the line in the Y axis, but he other needed to be rotated, when I rotated and then tried to increase the height (so it was a line traveling in the X direction, it was rotated 90 deg so it’s now traveling in the Y axis) my change would modify the wrong value. If I copied the part and then modified the height, it would actually change the width and vise versa. I had to paste a copy, change the length before rotating to get it to work.

I also ran the gantry plates that Phil created, when I simulated the tool path the job ran fine. I had one plate and then the other about .375 above the other so it would do both. The pocket tool path for the bottom plate ran fine, it would run the pocket, go back to the start and lower in the Z and run the pocket path again. The top plate, the tool path called for Z to cut about 3 passes, then lift all the way, move over to another spot in the pocket and then drop down and finish the pocket - seemed strange.


The calculations are done on your local machine.

The more points you use the longer it will take to preview & generate toolpaths, but there’s no hard limit. When Easel samples curves, it calculates enough points to reach a resolution at least as small as one stepper step on a Carvey or X-Carve. I wrote a little about this in this thread: Smoother curves

1 Like

@PhilJohnson, were you able to create a project? if so could you please share it? Otherwise, could you send the svg file or any other method to simulate the problem.

1 Like

I’ve noticed the exact same behavior on my bathymetry carvings. I’ve done many before with no problem but the exact same easel project now exhibits the same behavior Phil is describing.

Something has changed. This, along with the constant slowdown of auto-saving on a slow wi-fi signal is really depressing. :frowning:


I recreated your project in my machine (Eiffel tower, 0.016in bit size), it took 2 minutes to generate toolpaths. Given it’s complexity, I believe it took that much of time.

A older than dirt intex toughbook upgraded to xp works fine also tried on my ailenware mx15 that is 7 years old running win 10 no issue. The only times I have had issues like yours in easel have been from network lag, browser updates, and inventables updates. I make tool paths that are in excess of 3 million lines of code for the laser and 3d paths over 1.5 million lines of code I could be looking at this all wrong but I wouldn’t think that your computer is the issue

1 Like

@PhilJohnson, what is the configuration of your machine (processor, RAM)?

I’ll have to check the conf. on my old laptop, also, which runs Win7 on a SSD I installed. In the good old days (a few weeks ago!), it would take about 2-3 minutes to generate the paths for my Lake Superior bathymetry carve but now it takes much longer, if it even finishes at all.

Oh, I’ll add this too: I have a few much better desktop machines available for me to use at my home but the problem is I have to bring the laptop into the house to open a new easel project or tab. Slow wi-fi to my workshop is killing me (along with the constant auto-save “feature” ).

1 Like

I make the paths in fusion, artcam, and pic laser. some are imported into easel. I guess what I was trying to say is I believe it to be a easel issue or something other than the computer. You could bring up the task manager and see if it is eating up the processor and memory when trying to run easel.

1 Like

We are investigating whether the new tool path architecture negatively impacted performance in Easel, and if so, to what extent. If we find a connection, we will work to mitigate it.

If you have a project that was carveable under a previous version of Easel but now isn’t, and if you give us permission to review it, please post the link here. (Note that you can keep the project private and we will be able to see it even if you don’t share it publicly.)

In the mean time, for files of high complexity, you will have the best results by simplifying SVG files before importing them into Easel. In many cases with complex SVGs, the complexity comes from tiny details that won’t appear in the final carve even if you’re using a very small bit, so by simplifying, you may get better results. We realize that having to simplify projects outside of Easel isn’t the easiest or most convenient method of carving SVGs and are committed to finding a better long term solution.

1 Like

Can you provide the Easel project URL? Only Inventables can see private projects, and we will only look at them if you give us permission.

I’m seeing similar projects that used to run really smooth - now taking quite a bit longer to generate and then the carves aren’t going as smooth as they had previously.

@JeffTalbot - here is a link to a few of my private projects that used to generate quickly but no longer does:
I’ve carved a bunch using the contained logo - and now - the results aren’t as great. Message me if you have any questions. Feel free to check out anything else in my projects area, if needed.

I’m a newbie - but I noticed that this project, when tested doesn’t carve near as cleanly as it used to. Did the recommended settings for Birch Ply increase? It seems to try to carve much faster than before, as well. Again - new to CNC, so I could be talking out my rear.

EDIT: I do still need to upgrade my X-Controller firmware as the most recent communication mentions - but even generating a simulation is slow and I would think be unrelated to the firmware.


1 Like

bathymetric carving

Here’s one that is significantly slower now than earlier. I’ve done at least a dozen of these - some bigger (28" by 18") and although they’ve always been somewhat slow to generate paths, now it takes a good ten minutes or so, if they can finish at all. I tried one again last night. I had to hit the “kill or wait” wait button about ten times.

1 Like

I did manage to get my end of things updated (firmware-wise) and tuned up (had to adjust wheels and belts to get a X axis wobble out), so I’m back getting the same level of carve quality I had before - but with the projects I linked earlier - it’s still taking longer than usual to generate toolpaths. Not as long as Paul and Phil point out - but compared to what it was before, it’s considerably longer.

I did notice that these files take longer to do pretty much anything now. For example, clicking a group of shapes used to work pretty smoothly - now Easel takes a bit to think about it before catching up with what I’m doing with my mouse.

Anyway - this is behavior found on both of my computers - one speedy MacBook Pro running Easel via the latest Chrome build and one average Dell running Easel via the latest Chrome build.

1 Like

I tried using firefox instead of chrome and it seemed to help.

Thanks for the additional information, everyone. We are investigating and will follow up when we have more information.


Hi everyone,

We’ve identified some areas of slowness that may explain some or all of the performance degradation you are experiencing with the new toolpath architecture.

For complex designs, rendering previews of the carving can cause a browser to hang. We’ve restored a timeout that disables preview rendering if it’s taking too long. We’ve also deployed a change that should slightly reduce memory consumption when generation toolpaths.

Additionally, we’re currently implementing some changes that should significantly speed up toolpath generation time. We’re still measuring the impact of those changes, but we expect to deploy them within the next couple days.

Thanks everyone for your help on identifying this issue. We really appreciate the feedback and information you’ve given us!



I’m not sure if I understood your initial question as you meant it.

The calculations are done on your computer—as opposed to on the Easel servers in “the cloud”. But they’re done in your browser, not the Easel driver, so all you need to do to get any updates is to reload your Easel project in your browser.

1 Like