What is the new camand in Easel for Plung rate. Have had issues since this update

Since this update I have had issues with the depth of first cut being to deep. default seems to be 9 in /min but it causes the bit to sink almost a 1/16 on first cut then belts start slipping. it already cost me a set if belts.

The plunge setting is the speed that it moves. It shouldn’t be affecting the depth.

1 Like

it is also in the recommended. just cant change it.

I switched to custom and changed it to 15 and it seemed to cut the depth in half it was cutting the first pass but still deep.

This new option adjusts the speed at which the Z moves up and down. It shouldn’t affect your depth (plunge) in any way.


Are you sure you’re setting the home (Z especially) correctly?

Yeah - I used the custom setting, and set it to 6 instead of 9 so my bits would quit breaking. Just slowing down the plunge speed saves those 1/16th inch bits quite a bit.

1 Like