Where is the buffer pull down in chilipeppr grbl

Easel works great. Got Jason installed. Grbl selected on Chilipeppr. Chilipeppr tells me to select Gbrl buffer on pull own before connecting the arduino. I don’t see it I connect anyway and I can jog fine but when I start the project it starts fine then goes crazy I think when the buffer is overflowed but I can’t see a buffer like it shows for the tinyg on the YouTube tutorials
want to use v carve and that is what I am trying to carve is there sample also trying to carve the Chilipeppr sample

Looks like you’re TinyG user. I have GShield. Chilipepr always gave me problems, one after other. I stick with UGS 1.8. Instead of digging into troubles, I’m carving non stop.

I gave up on TinyG and Chilipeppr after having issues much the same. I switched to the Planet CNC controllers and love them. Sort of the same thing as doing UGS but on steroids. Chilipeppr and TinyG just have too many bugs and once they iron them out, they add new features (which is on one hand nice) but then all new bugs. I just got sick of having to update firmware and the JSON server file nonstop to reduce (not stop) crashes. I learned to mill on the TinyG and Chilipeppr and it was great back then. far too buggy now to trust with $100 plates of stock.

Your best bet would be to head over to the chilipeppr forum and try to get it settled down there. Does not sound like buffer issue to me, but I stopped milling with Chilipeppr a few month or so ago and have purged much of it from memory. Too many mid-job crashes for me.

Thanks for the help. Used ugs 1.8 worked great. This is the Vcarve box front demo. 20 min with stock spindle and 60 deg. V bit

Indeed not picking the correct buffer will ABSOLUTELY NOT WORK and make your controller go crazy. So this is a buffer issue. The default buffer is picked for you in each workspace, so this should not be a problem. The only reason it would be a problem is if you override the pulldown menu. Keep in mind ChiliPeppr has over 4,000 active monthly users so folks are having a lot of success with it.

If you are actively connected to your controller, the buffer pulldown is locked. So the fact that you can’t pick from the pulldown is because it’s locked and you’re connected. So disconnect from your device and then choose “grbl” from the pulldown and then reconnect. You should be good to go.

I never had buffer issues John. I was milling with a TinyG and always had the Tinyg picked in the buffer and never had those sort of issues. I had more issues along the lines of just straight lock ups during things like probing a large PCB for milling. About 1/2 to 2/3rds of the way done it would just lock up and all the time probing up to that point was lost. When you are on a deadline and milling a large number of projects for clients each week, lost time like that can really start to hurt and become a source of much frustration. I had great success with the TinyG early on with Chilipeppr and loved milling with it. I did some really great aluminum work on the Shapeoko with it like this piece which has everything from the crabon fiber tubing to the entire aluminum body (put the silver heat sink) milled with the TinyG and Chilipeppr.

At the time this was milled there really was nothing else out that could mill this type of project with such ease as Chilipeppr.

But the later editions of Chilipeppr started to really act up for me. I was also faced with internet access issue late at night when I would be milling my larger jobs If I was unable to reach Chilipeppr then I was unable to mill. While this is not really an issue where Chilipeppr was at fault, it kept me from working with that program so I was faced with trying to find a new way to keep my mills milling as often as I could to keep up with demand. Overall after about Json server 1.70ish, I started having more and more issues. The firmware on my TinyG was a major pain to update as it would only work with the CMD line method and none of the updating apps built into Chilipeppr.

I really enjoyed Chilipeppr but I also started to find a demand from clients for things like digital 3d probe digitizing and 3D probe dimension checking which were not supported yet in Chilipeppr. I am also changing over to an ATC system on my larger mill which also was not supported in Chilipeppr when I was milling with it.

The Chilipeppr community is a large and active one and I know for 95% of everyone I know who mills with it, it works great. I just reached a point where it no longer worked for me in the way I needed it to.

If you are running a TinyG then you don’t want to go to the GRBL section of ChiliPeppr… you want to go to the specific TinyG section here:


Not this one:


John I love how Chilipeppr looks and works until I send the code then it does go crazy. I know it must be me doing something wrong.
I load the grbl workspace. Above the port select it still tells me to choose the right buffer in the pull down before choosing the port, I don’t see any other pull down
I have Jason running it connects fine i see the arduino on com 3 I select it I can jog fine I load the gcode in inches Chilipeppr is in inches it starts but I don’t see any buffer the code just runs supper fast and my Xcarve gets lost.

Brian, you need to pick the correct buffer in the buffer pulldown. If the pulldown is locked it’s because you are connected. You need to disconnect and then choose the correct buffer and then reconnect.

I need to repeat this because it does seem like folks keep changing the default setting. You MUST pick the correct buffer or your CNC controllber will go crazy because it overflows the buffer.