Which software works with a laptop with usb

Check your G Shield connection. If that is good pull your Arduino and run Blink from the Arduino IDE program. If that works you may have to reflash your board with the bootloader, check forum for bootloader

tried l\blink ,got error
tried bootloader ,cant find usb device

Got another Arduino sittting around, you may need it

i ordered one ,what could i have done wrong?
ardurino or gshield or both?

Maybe spike voltage from something :zap:

In order for the machine to connect it needs:

  • installed and working device driver software
  • good quality USB cable connected to a working port
  • Comm program w/ correct settings
  • Arduino which has Grbl installed and functioning
  • gShield in working order

Check each aspect of the chain to see what’s wrong. Fixes:

  • uninstall and reinstall driver
  • try a different cable or port
  • check settings or try a different program
  • re-flash the Arduino, clear the EEPROM area
  • check gShield connection, test gShield

I’ll repeat my earlier question: What version of grbl are you using?

There’s a difference in baud rate going from 0.8 to 0.9 - 9600 to 115200

Im not sure ,for now Im waiting on the new arduino board

I did try both baud rate settings

Sorry you are having trouble @DanHenry Have you been in contact with Inventables customer success team? They can walk you through getting it fixed and replacing any defective parts free of charge.

No, I’m not worried about that ,it worked when I got it .
I ordered another, and I will give it another go.
I get frustrated but I don’t give up,

Flashed the arduino ,it’s working again!!!
I’m using GRBL latest build

Yay! :smile:

What does it mean to flash arduino? I know what the arduino is (I think). What is it to “flash” it?

Hi everyone. Easel is good for 2.5 d image. Which software do you recomend for a 3d object. I wants to work with wood and also aluminium. ?

Thanks. I’ll be giving a look. Is this something I’ll have to do before I can use my new machine, or is it predone at the factory the first time?

If you get a machine now, it will not have an arduino. The new machines use the X-Controller.

I see. So learning about flashing the arduino is rather a moot point, eh?

I have window OS on my laptop and I have faced the same issue which I have solved with help of hp touchpad not working. So You can ask you here with your problem like me

have you run machine setup in Easel?