Why won't this very basic shape import into Easel correctly?

I made a very simple diamond (11.5mm wide x 6mm high) in Inkscape and attempted to import it into Easel. Easel imports a 6.1mm square rotated 206.5 deg. This makes no sense! (screen shot attached)

Specifically, I make a square in Inkscape, rotated it 45 degrees to make a equal-sized diamond, then changed the width to 11.5mm and the height to 6mm. The result is the image on the top of the attached screen shot. The Easel imported graphic is the lower shape.

I’ve also tried exporting as a PDF from Inkscape to use Image Trace in Easel, but noting imports. I’ve also taken the PDF, converted it to a JPEG (via Mac’s PREVIEW app) and imported into Easel. While the diamond comes in, it’s not usable as it has wavy lines and much too big. I’m doing inlays so a high degree of accuracy is paramount.


But it’s not text, it’s not a DXF file, it was created in inkscape so no images are embedded and it isn’t from a traced file so certainly not complex. It’s a square that has been resized and rotated.

Seems pretty basic. I’ll try making a diamond from 4 straight lines. See if that imports. Any other ideas?

Making a diamond from 4 straight lines worked. For those that run into a similar issue, once I made the shape using multiple lines, I joined each end node from each line to its adjoining end node. This completes a shape that Easel can use.

Not being able to import a basic shape from Inkscape seems less than a feature request and more like a bug. But at least there’s a work around.

I believe that this is what @JeremySimmons was trying to get you to read from this article. it really has some good info in it.

Traced images often contain many unneeded paths that can choke up Easel, including white filled background paths and extremely small noise paths that aren’t desired. It is much easier to simplify this SVG in your vector editor before bringing it into Easel.

Doesn’t matter. Use Ctrl+Shift+C to convert it to a path. if it doesn’t work, attach file and I’ll fidget for you.

Sigh, yes I just tried and that worked. I really did read the article but I didn’t see how those items applied to what I was doing, e.g., not TEXT, not DXF, not a TRACE of an image and no EMBEDDED IMAGES. So basically any object created with Inkscape, other than line art drawings, need to be converted to PATHS.

Thanks for all your help, patience and fast reply!



Not sure. Also, try “Optimized SVG” as the format when saving

I believe you. Don’t sweat not trying the first time. Carve it up and share your win!

glad to help. I just happened to get here first. If I hadn’t, someone else would. Stick around and help others out when you can. This is one of the best online communities I’ve had the privilege of being a part of.


The SVG standard seems to be the heart and soul of Inkscape and the software utilizes the full spectrum of SVG primitives such as circles, arcs, rectangles, text, and other objects. If you were to open an SVG file in a text editor, you’d see that it is actually a list of instructions in an XML container.

Easel’s SVG importer is less sophisticated and seems to support a subset of SVG instructions, chiefly the PATH command. Other objects such as circles, squares, rounded rectangles, text, etc. will be lost when importing to Easel. The solution is to select all the objects in your Inkscape project and Convert Object to Path. This can be done in 1 action. This throws out all the SVG shapes and converts the entire document to a bunch of PATH statements, so you should perform this action on a saved Copy of your Inkscape project.

Note that there is a issue within Easel where some SVG path coordinates are misinterpreted, resulting in paths being drawn in the wrong positions. This is especially apparent in text which has been converted to paths. The result is unusual spacing which must be corrected by hand in Easel. I know no fix for this issue.

1 Like