Wont do set up

So i finished building my x carve and i get to the point that i have been waiting for.
It tells me to do the set up. I click the link and it ask me to download a driver. I do that and unzip the file. Go to easel and click machine and the click set up and it just brings up the same page to download the driver. I also downloaded the FTDI driver and unzipped the file. restarted the computer and same thing every time.
Please help i really dont want to have to wait till monday to get this thing running.

Hey Eric,

Welcome to the Inventables forum. I too came into problems with the initial setup of my X-Carve. My issue came down to the USB port on the X-Controller experiencing EMI. Upon reading the forum, many users described the same problem. I found out that bypassing the USB header on the front of the controller I was able to successfully connect. This is my story.

Not having enough information in your post to see where you are at Iā€™m going to suggest some deep searching. Once you find a post that describes your problem try the solution that worked for that particular user. Problems range from E-stop button, USB to improperly seated ribbon cables. Start with the controller and work your way through.

I often find wording in a post that correctly describes my issue and then search that. Some people use different explanations for the same problem.

Stay with it. It took me several days of intermittent troubleshooting until I finally figured out my problem. The benefit in this was I was more familiar with how the process worked afterward than I did in the beginning.

Is your X-controller lighting up? Is the E-stop properly pulled up, or wired properly. There are only a few parts to troubleshoot and you will be on your way to arving in no time.

Many post to look through that will provide you with a solution before the weekend is up, and quite possibly before many respond with help. It will come, but within your required timeline is not guaranteed.

Good luck, you will prevail.

1 Like

i found the problem. I forget to install it after i unzipped it.

Thank you

Well done. Glad you found the solution to your problem. Happy carving!

1 Like