Work and machine coordinates

I have an X-Carve 1000 with homing switches and X-Controller which I run with Grbl Candle 1.1.7

When a job completes the gantry moves to top right of the X-Carve rather than bottom left. I “think” what I want is home and work coordinates to be the same and to be at bottom left (X=0, Y=0). I assume if this was the case, the gantry wouldn’t go to top right when the job is complete.

What does the last 10 lines of gcode say?
I think that in your CAM an “end of carve” position is called.


Jupp, G28

Its during the CAM-process this is added to the final gcode, what design/CAM program and post processor do you use?


You can uncheck the G28 Safe Retract box which you´ll find when you click post process / Properties.
However, the G28 is probably a point you have defined no? If so there is no harm, work zero is still preserved.

You’ve probably never set a G28. By grbl default, your machine origin is back right. Your G28 offsets are, by default, 0,0,0. So zero mm from the machine origin, back right. Just do what @HaldorLonningdal suggested, use a different post processor, or set your G28 where you want it.

I don’t have a Post Process/Properties?

G28 Safe Retracts…on the right side, in green. Change it to “No”.

1 Like

Ah, yes. Thanks