“work offset has not been specified. Using g54 “

Hi.

Just wondering if anyone can help. I’m using fusion 360 post processor for a few years now with no problems.

Now when I start my cutting cycle the machine z goes straight up to the cutoff switch.

I’ll show a couple of screen shots below.

In fusion it tells me that

G54 is a saved offset, that would need to be saved onto the cnc chip itself… if youre not thoroughly familiar with gcode and saving offsets, then I suggest changing the post processor option from g54 to “clearance height” its much easier anyway and you can change the post processor defaults to always use this setting.

If you were using it for years without issue im prone to believe that you have been using this setting of clearance height from when you first set it up and a F360 update reverted the post processor settings back to the g54 defaults

In fusion, when in manufacturing and creating a Setup, under the post process tab, set your WCS offset to 1. This will solve your issue.

G54 is the default WCS for Grbl. When you set your work zero, by default, you’re setting it G54. Fusion added that check a while ago. Your gcode always had that G54 before, I’m sure. If you want to get rid of the warning, do what @JeremiahRatledge suggests.