Working fine for years until today

I have used my Xcarve sporadically for a couple of years. This year I started using it much more. I have successfully completed a number of projects until recently. All of a sudden things have been going haywire. First I started noticing about halfway into a carve the machine not able to clear the material to move to the next cut. Then when I stopped the carve and tried to raise the Z axis, the spindle actually moved down instead of up. I was able to restart the computer and Xcarve and go back to carving normal. I successfully completed another carve. Then I tried a new project, the roughing pass worked fine and then on the detail pass things went crazy again. This time the bit went far deeper than the cut or depth per pass were defined. I went on a Facebook group and some people suggested a new USB cable as well as setting up a new machine. So that is what I did. I went into Machine > Set up new Machine and walked through the prompts. My steppers were not moving in the right direction at first but the dialog box automatically reset GRBL so everything was oriented correct. Then I did the test cut which I will attach here. It looked mostly fine except for one of the eyes wasn’t perfect so I figured I would try another carve project to test it out. The roughing pass went fine but then the detail pass drove the bit into the material way deeper than my settings on one particular section. I have also attached the photo here. I am using a 60 degree bit for detail and the cut settings are Cut Depth = 0.0469 in, Feed Rate = 85 in/min, Plunge rate = 22 in/min, Depth Per Pass = 0.025 in. Any ideas on where to start to troubleshoot?


What type of Z-Axis do you have?

Have you checked the stepper motor electrical connections?

{:0)

Brandon Parker

3 Likes

It was the Z axis red wire on the controller, it was loose! Thanks. I also noticed a number of my V-wheels were loose. After tightening them not all of them turn when I manually push the router along the XY axis. I have tried loosening the ones I tightened to see if I over tightened but that did not change things. Shouldn’t they all engage and rotate? I also slightly damaged one of the connectors on the stepper motor side, part of the white connector broke off when I was removing it. The black lead has part of the wire exposed. Do you think this is a problem? Do you know if I can just replace the white connector without replacing the entire wire assembly?

The v-wheels should be tight enough against the rail such that they are not loose, they can be forced to rotate with a little applied pressure, and are not so tight to force the wheel into the rail too much as this will cause the wheel to split into two pieces.

As far as the connector goes, is it on the cable? If it is, you can replace that one. Until you can source the replacement part, you can put some hot glue over it to keep anything from getting into the connector and shorting it out as well as keep everything in place. A picture is worth a thousand words here. Can you post one of the broken connector?

Here is the link to Inventables’ stepper motor cable assemblies.

Here is a link to the 11-position JST connector on Digikey, but you can source it from many other places.

{:0)

Brandon R. Parker

Picture attached. As for the v-wheels, they are as tight as I can get them and they still spin free without engaging the rail. Any thoughts?

Yup…I would probably put some hot glue on that and call it good while I waited on a new one.

As for the V-Wheels, can you post a picture of the offending section?

{:0)

Brandon R. Parker

Great, I have put on some glue. Do you know if I can buy that as a replacement part? I have also attached a video of the vwheels. I can spin three of them by hand and those are the ones that do not turn when I manually push the XY gantry back and forth. I had to upload the video to my youtube page because it was too big:

Thanks for the help.

I do not believe Inventables sells the JST connector by itself, but you might be able to contact customer support and see if they could do something for you. The part is readily available elsewhere though…

The video is still set to “Private” on YouTube, so I can not view it.

{:0)

Brandon R. Parker

try this

Say hello to my little eccentric friend, the eccentric spacer…

image

Just run back through Step 3 of this page.

Just loosen the nut on the back side and then rotate the eccentric spacer until the v-wheel becomes snug enough against the makerslide and then tighten the nut again. If the nut does not have a nylock insert, I would add blue Locktite to the bolt/nut. Heck, you can add it to the nut even if it does have a nylock insert.

{:0)

Brandon R. Parker

2 Likes

Sorry for the delay, the holidays got away from me. But thank you for this fix it worked for all of the vwheels that I could access. However there is one in the back that is too close to the raling to fit an allen wrench into. See attached picture. Any advice on getting in there without taking the gantry apart? I guess I could use an angle grinder on the allen wrnech I have to shorten it. Thoughts?

Are you talking about the top, back V-Wheel? If so, that should be a “fixed” wheel…as in it should not have an eccentric spacer on it. It should have just been tightened during assembly. The eccentric spacers are on the bottom only. If there are eccentric spacers/nuts on both the top and bottom you could adjust the X-Carriage to the point where it would not be perpendicular to the X-Axis Makerslide. The “fixed” top V-Wheels act as a hard reference to the X-Axis Makerslide. The bottom wheels adjust to compress the two sets onto the edges of the X-Axis Markerslide.

If the top ones are loose, you should tighten them up per the installation instructions above. I thought everything was still accessible after assembly…

Here is an oversimplification of what could happen if you had eccentric spacers/nuts on both the top and bottom of the X-Axis gantry. FYI…the newly updated PAINT on Windows 11 is complete garbage… :slight_smile:

{:0)

Brandon R. Parker

The eccentric nut (which is really a spacer not a nut as it has no internal threads) adjustment is made with an open end wrench.

No allen wrench is used for this process.

the process is also explained here about 2/3 down the page… Calibration and Maintenance - X-Carve Assembly