X and Y axis "jumps" when moving far/quick

After cutting a few small projects, I am moving on to some bigger projects (30x20cm).

I’ve noticed that when I push either the X or Y rail, it creates some noises, and the X or Y carriage “jumps” on the rail.

The belts are as tight as they should be, And there is no slack or movement at the excentric nut V-wheels, at least that is what I am telling myself.

I have attached a video link with the issue.

Any advice?


Looks like you need to increase your current to your motors, they are struggling to move at that speed! There are adjustments for each axis the the Grbl shield. There are also some other posts in these forums that go into detail on how to adjust. I had the same problem and adjusted them ever so slightly and it did the job. And I would only adjust the axis you are having problems with!

But it is when I am pushing the slides when the power is off? … To me its more like a mechanial problem.

Does it do that noise in the same spot every time? (bad spot in the rail?)
Or when you start to move it over a certain speed? (steppers generating power and interfering with one another?)

My best guess is to trouble shoot it by disconnecting the belts and see if it still “drags” in that spot.
If so then it is probably mechanical.
Double check your pullies, belts, set screws, eccentric nut, etc. Look for damage or debris on the track…

If it does not do it with the belts disconnected it could be a stepper wiring issue. I would work backwards form the controller. Disconnecting at each stage until it stops doing it. That should help isolate the problem area.
Things to look out for.
-Loose wirers (Common problem)
-Incorrect wires (Usually wont work at all if this is the case)
-Short (a stray bit of wire sticking out of the terminal strip)
-Screws from the cooling fan shoring against a controller pin (read about this one today)

Oh I thought you were jogging the axis!! Then I would say that it would be mechanical. I know you mentioned that your eccentric nuts for the V-wheels had no slack, but you also want to be sure they are not over tight, thats where I would start. Back of all the v wheels and then tighten them only until you feel them starting to snug up against the rail and dont spin freely! If it is mechanical, the wheels are the only thing that could cause a vibration I would think.

Update: Aaron has better advice, go with that! lol

Will try that! … It is not at one spot, it’s more when I push the Y axis at a certain speed.

That sounds to me like your motors are feeding current back into the control board and when you move them too fast it produces enough current to drive the axis for a short period. You can see this happen when the power to the controller is off. When you move the axis by hand you will see lights flash on the gshield. A little bit of current is not harmful, but moving them fast/often is probably not a good idea for the health of your controller. Either stick to jogging in the software or move slower.

It also happens in Easel - if I try to jog the Y axis ex. Above 30-40mm it happens too.

Wil try disconnecting the belts tomorrow and do some testing.

wow, ok that’s weird then. I would think it has to be something mechanical if it’s failing both manually and when driven by the electronics. When you say “jump”, I’m wondering, is it maybe that the friction is less at some spots along the rail or something? So maybe it’s hard to move initially and then at some spots it moves more freely. Do you feel like that describes what’s going on accurately?

Also check every V wheel, visually through a complete rotation. One of mine, on the right Y plate is slightly skewed but doesn’t affect anything.

Also, pushing too hard on a connected stepper, even without applied power can cause problems. E.g. With power disconnected, pushing the gantry backwards too fast, causes the green Y light to come on, which in turn powers up the coils of the motor causing it to try and brake which in turn can cause belt slippage. If you need to move in any direction, jog it where you want it, then power off, e.g. A material change where you need to get the gantry to the back of the machine. Steppers are not like DC motors, they brake with almost the same torque as they drive.

1 Like


I took of the belts, adjusted all wheels according to your advice and the Inventables “Tuning Video”.

The gantry runs smooth on the Y axis without the belt attached.

After putting the belt on again and adjusting the tightness, the problem accures again.

When moving the Y-axis more than 4-5cm by hand or jogging it in Easel, the starts jo “brake” and makes that awful sound.

I am getting a bit frustrated.

And it also looses zero when it happens.

Have you adjusted the current pot for that axis?

It sounds like you have eliminated any mechanical / adjustment issues with the v wheels and track.

A stepper motor is also a pretty good generator. So when you are moving it by hand they are putting power back into the system. (not the best thing for the controller.)

With the belt still attached try unplugging the stepper wires form the controller. See if it still does it.
If it stops doing it the problem may be in your controller. It could be damaged or something could be shorting inside. Double check the wires going into the green connectors. Make sure their are no loose ones or stray wire strands sticking out. Look really carefully at the gshield pins and make sure they are not shorting on the case (a lot of people soldered theirs in upside down so the bend is too close to the circuit board to clear the case), check the solder joints for cracks or shorts, check that the fan screws are not touching anything, etc.

If it still does it with the stepper wires disconnected from the controller try disconnecting the wires at the stepper motors too. You should tape them so they don’t short against anything.
If it stops doing it then something is weird in the wiring between the motors and the controller. Double check everything. Make sure there are no crossed wires. Look for stray strands of wire sticking out of connectors, etc.

If it still does with all the wires disconnected it take a good look at your belts and pulleys and see if something is binding or out of whack.

If it is still doing it after all of that… um try spinning each stepper by had with it disconnected from everything. See if the stepper drags, binds or clunks all by itself. If it does then it might be a bad stepper.

My guess is the problem has to do with the steppers acting as a generator when you are moving it by hand. The concerning part is that it happens when jogging it in easel too, that is not a good sign.
That suggest whatever is going on may have damaged the controller as well. If you do find a issue in the electronics and fixing it does not correct the problem you may need a new controller. But I would make sure everything else is fine before replacing the controller to eliminate the risk of damaging the new one as well.

I tried disconnecting all wires for the Y motors and reconnecting them.

Afterwards I pushed the gantry all the way to the back and adjusted the belt tension.

I launched Easel and for now the Gantry/Y-Axis are moving flawless, I will test it with a carve tomorrow, if it works I will mark this subject as solved!

Thanks to @ThomasGonzales - @JamesSinger - @IanWatkins - @TonyNo and specially @AaronMatthews for taking your time and effort to help me :smile:


I suspect that the issue you’re having is actually related to the setting of the current to the stepper motors (see the thread I had relating to setting motor current).

When I push my machine from point to point, if I do it slowly, things are nice & smooth, if I try and move it rapidly (or I’m pulling the Y axis slightly off-square) it jumps and feels like there’s a ‘bump’ in the rails or something mechanically wrong.

Try doing this:

  • Get access to the card (remove the fan)
  • identify the ‘pots’ (potentiometers) for each axis - the white boxes with the small screw slot in the top.
  • Set your machine to air-carve (no bit in the collet and spindle turned off) a nice complex pattern that has lots of movements in it (a 3D flower or something)
  • VERY CAREFULLY, slowly adjust one pot at a time until each motor runs nice and smoothly (note each pot is delicate and has less than one revolution of movement - when I say “adjust” I mean turn the screw a few degrees at a time.

If the current is too low, the machine will stutter or make a growling noise, similarly if the current is too high it’ll sound similar. Try adjusting each pot until all you can hear is each motor smoothly indexing back & forth.

I swore that my machine had a handful of loose nut & bolts rattling around inside it, but adjusting the current has both silenced these noises and fixed the problems I’ve been having with sometimes losing the X or Y position during cutting.

If you’ve not adjusted these pots, I’d strongly suggest doing this anyway - if for no other reason than it’ll need to be done at some point anyway. I suspect you’ll see some big improvements in operation.


1 Like

For the “clunking”,“clicking” or “Jumping” on the rail every rotation of the motor spindle, check for an over tightened eccentric adjustment nut(bottom rollers of the gantry). I found it had nothing to do with the motor because it was happening even when the pully belt was disconnected. Loosen the eccentric nuts and notice how the jumping goes away. Tighten again, just pay attention to the nut and be sure not to over tighten against the rail. I hope this helps.