X axis homing won’t stop + skipping sound

Hey guys I had bought my uncle a x carve for his birthday and we are having a issue with it. I got the thing completely built and when I send the machine to do a homing sequence, what happens is there’s a rubbery grind/slipping/minor jumping sound on the x axis and it jerks slightly and takes awhile to get to the x homing switch, then once it’s at the homing switch it keeps going and going and won’t stop. I’ve tried adjusting the belt tension, the v assembly wheels, and the spacers. I’ve also made sure all of the wiring isn’t loose. No luck on the rubbing/grinding/skipping sound. The homing switch I’ve tried tightening them up by making the connectors smaller and even in the machine test part of easel it shows that they’re all working. Not sure where to go from here boys. Thanks -Aaron

  1. I suspect you have over tightened the two screws that attach the plastic acme thread block.
  2. You mechanical Z stop is too far down preventing activation of the micro switch.

When it shows the switches are working, are they working for the correct locations? It’s possible that the connections on the back of the X-Controller may be swapped and X limit is connected into Y limit

The connections are solid, I made sure of it cause I was having issues with the Y1 moving faster than Y2. When I went through the machine test page (Cant remember exactly what it was called) I checked each switch in a row.

1 Like

OKAY, I got it fixed. Issue was with the V wheels needed to be tighten and in Easle the Y axis forward and back was swapped. The Y axis was actually bottoming out on the back of the machine and it made it look like there was a issue with the X axis

1 Like