X axis moving 4x as far as it should be after moving x axis POT

So, I tried multiple times to flash the one from https://github.com/inventables/grbl

It does not change the settings and even jogging it via UGCS does not change it.
Edit - I forgot to issue the reset command but it still doesn’t jog the correct amount.

I’m a little confused.

Did you try multiple Arduinos, multiple uploads? Did it upload succesfully?

The last set of parameters that you posted look good unless you have the 1000mm unit. The settings that change for that do not affect the distanced traveled.

Different Arduino - Inventables Fork GRBL upload - Issue Reset command -> Back to the original X axis moves 40mm when told 10mm … The last picture in the post was the latest parameters.
I do have the 1000mm Unit

Ok, it’s very unlikely that you have two bad Arduinos with exactly the same problem, so I think the gShield is bad.

For the 1000mm unit change $130 and $131 to 790

Alright, could you point me to the page that explains how to actually change the parameters?

Second thing - I should contact support about getting a new Grbl board or would this be something I have to pay for outright? The annoying part is because the X axis began moving so fast the first cut I did it snapped the bit too. lol

Thanks!
Brent Sancken

Yes, contact support. Inventables has been really good in supporting it’s customers. Most likely they will replace it at no charge, but I don’t work for them, so I can’t say for sure.

You can use UGCS to change grbl paramters. Go to the Command Tab and just enter $130=790 and $131=790. You can issue a $$ command to verify the changes.

its exactly the same problem as mine, the x axis moves very fast and jerky. And it moves to far, but not the same amount every time.

@JarnoOoink

Yes, I think it is. And in this case I think its the gShield because we tried a second Arduino and the problem is still there. Your problem may also be the gShield.

Do you have a second Arduino to try?

I’m having the same problem with excessive z-axis travel (about twice as far as should be) This just started tonight. I’vew been carving perfectly for the past 4 months without a glitch. Fired up the machine tonight, wanted to carve a piece for my dust shoe project and went about 0.5" into my waste board unexpectedly. My machine settings are as shown below.

Anything stick out to anyone? What about $102 ?

Is there an easy way to dial in the Z-axis with the potentiometer?

The $102 setting in your grbl parameters is for the M8 threaded rod. If you have the ACME screw then it should be about 188.976.

The potentiometer only sets the current limit for an axis. Doesn’t affect the distance moved, only the force that is applied by the motor.

1 Like

Thanks a million @LarryM! That’s all it was. How the heck did I overlook that like 10 times? LOL.

1 Like