X axis moving 4x as far as it should be after moving x axis POT

So I was trying to cut out a dust shield and it first cut a perfect circle but then began cutting the outline of the shield through the center of the circle, so I thought oh I never “calibrated” by tuning the POT’s. So I read the guide on it and tuned the Z axis, and then the Y axis, those went fine.

But when I went to turn the X axis all the way down , then back up while jogging it to see when it began to move reliable, It seemed to be moving excessively fast. Turning the POT down didn’t help, as it just failed to move then. (Side note, had it “fake cut” a circle and it should have started an inch or 2 from home but instead the X axis shot across the machine to the other side and started tracing an obvious oval (long on the X axis, fine on Y — spindel not on, homed above an empty work area so it wont cut or hit any material- )

I set the bit to a known spot on the board and jogged it 10mm on the X axis and then measured the ending location at being 40mm from start. Did the same for the Y axis and it only moved 10mm.

What has happened? I have “rebooted” the machine by turning off the PSU AND unplugging it from my computer. I am jogging it from within Easel.

Any help/suggestions are appreciated!
Brent Sancken

EDIT - Also forgot to mention, no there is/never was any jumper on the X axis microstepping pins. I did steal the one from the Z axis to see if the 4x setting solved anything and it appeared to move to the right distance except it was moving so fast it couldn’t stop right away…

The potentiometers set the current limit for the stepper motors. It is not really a calibration.

The calibration that most people refer to on the forum is setting the steps/mm parameters in grbl. Take a look at the grbl parameters (in Machine Inspector) to see if they have been corrupted.

To me, nothing looks alarmingly off –

However, I am curious as to why it would be in the software if I didn’t make any changes in Easel or any menu, Just jogged the machine.


The grbl parameters look good.

As with anything complicated you can run into problems at any time. It’s possible that you did something in a way that the software designer never tested.

You could use Universal G-code Sender to get another data point which might shed some light on the issue. If UGCS works but Easel doesn’t that might point to Easel as the problem, however, if UGCS does the same thing as Easel then it might point more toward your machine than the upper level software.

Just tried UGCS and it is still moving 40 mm in the X axis when told 10mm but only 10mm Y when told 10mm.

Brent Sancken

Try switching the X-axis and Y-axis wiring at the gShield as a temporary test. If your problem moves from the X-axis to the Y-axis, then we are looking at a hardware issue.

I switched them and the Y axis is now doing the 10mm to 40mm. It is also extremely fast/jerky compared to jogging the other axis. So could it be the Grbl shield?
Brent Sancken

So, we now know that the stepper motors are good and the wiring to the motors is good.

It could be the Arduino, the gShield, or electrical noise.

If you haven’t already, put the wires back to the original configuration.

I’m assuming that you are doing your jogging with the spindle/router off, so it’s most likely not noise.

At this point, it’s a long shot, but the easiest thing to try next is to reload grbl into the Arduino. If you are not at version 0.9j of grbl, I would load that version in.

Alright, I will try that and post another reply tomorrow as its late here in Illinois.
Thank you for all your help so far!
Brent Sancken

Could you have bumped a jumper?

Check all their settings, plug and unplug them in place a few times, then make certain they match your Grbl settings.

The gShield doesn’t have DIP switches.

Possible, but not likely.

There’s only one jumper provided/used on the gShield for the X-carve. It’s on the Z-axis.

Yep, just one. There are places to put others, but they are not populated.

Maybe this is a terminology problem. The jumper is the device you put on the header pins. If you have more than one jumper then you are not running a stock gShield from Inventables.

There are three sets of header pins, one set per axis.

It seems that reloading the Arduino has Not fixed the issues ----
I don’t know if this is important but I’m using the latest public version of chrome on a Mac.
Brent Sancken

I just spent some time reviewing a few other posts that have exibited similar symptoms. The problem could be the Arduino or the gShield, but I can’t think of an easy test to determine which component is faulty.

As I did in the other thread, I’m going to guess that there is a problem with the Arduino. If this were my machine my next step woutd be to replace the Arduino.

Thinking is that it is the less expensive part and has more to do with the number of step pulses to move a given distance. Your steps/mm are in the correct range for generating better accuracy than you are seeing.

If the guess is incorrect and you have to replace the gShield, then you would just have a spare Arduino. Not a bad thing.

Oh, and your microstep setup is normal.

Alright, I will replace the arduino uno as I have a few laying around. I reloaded the arduino one last time and not it is moving “sluggish” on all axis like it “ramps up” to speed.

Now when Issued 10mm move it goes-
approx. 70mm on Y axis
approx. 250mm on X axis

Now off to replace the Arduino!

Nope, still Ramps up and down and travels too far!

Ok. Guess it’s time to replace the gShield.

I checked the grbl parameters and some of them appear different? Is this something that would cause this?? How to reset those?

This is the same, it just shows the whole strings…

Yeah, that’s bad. If you loaded grbl version 0.9j from the Inventables fork then issue this command $RST=$

Should reset all grbl paramters to default.

If not 0.9j - I would load it.