X-Axis only moves to the left

I finally got my X-Carve all assembled and did a few practice cuts. The first one looked pretty good, but I noticed some wiggle in my Z-Axis and found that the eccentric nuts had loosed a bit. I was excited to give it another try with a real project.

Once it started it went off the material (it seems like it didn’t use the set home position from the ‘carve’ process). I tried stepping it back over to try again and found that it makes a ‘grinding’ noise when it attempts to move to the right…

With the power off, it slides in both directions along the X-axis.

Anyone have any suggestions??


You probably need to adjust the current limit pot on the gShield. Lots of threads on this forum that talk about it.

Triple check your stepper wires from that motor to your Arduino/G-Shield. Mine came loose a few times just moving the power supply into its final position.

Thanks for the responses!
I checked the stepper wires and one was loose (but still in). I tightened it up but same thing is still happening.

I was out of town since my post, so I haven’t had a chance to read up on the current limit pot, but I’ll do that tonight and hope it works!

Forgot to update! I tried to change the current limit but am not sure I moved it enough to make a difference. I also noticed the belt was slightly looser than I had originally set it. So I undid the screw and retightened it.
Everything worked fine again for a short while and it stopped again. I checked the belt again and it once again was a little loose.
I tightened it once more, but pulled on it this time and it started to come loose very easily, even though the teeth were engaged.
Tightened everything up again and zip-tied both ends and haven’t had any issues since.

Thanks again for the responses!

You may want to put a washer on the set screw used to hold the bracket in place.
Sometimes the set screw is just a hair to long and bottoms out in the t slot.
If you move the bracket you may see a small scuff in the bottom of the slot that shows this was happening.
Adding a washer fixes this. :smile: