X-Carriage keeps hiccuping

We reflashed the Arduino with The Inventables GRBL fork to try to eliminate any issues we were experiencing. We calibrated the potentiometer, checked all the wiring, We removed the “30 Minute Stiffening Mod”, and switched from easel generated text to vector text. It will be moving across smoothly, then it will just halt momentarily, then continue at an offset.

How’s your X-carriage pulley doing on the motor shaft? The set screws can loosen and allow some ‘play’ where when it changes direction the pulley just sits there for a moment before catching the other side of the flat face of the shaft. This usually manifests itself in circular cuts and appears as a ‘lobe’.

An easier way to test is to make circles in Easel using “on the path” and post back pics or video we can see.

We tried tightening the set screws, but we can try again.

Here is the cut we had issue with and here is the test cut. We cut it on a pine board with the settings for soft maple.

Here are parts 1 and 2 of the test carve.

Also, it seems to cut deeper than it is supposed to.

Here is the Easel file for the test carve.

Here is the Easel file of that sign, after we switched to a vector instead of easel generated text. It was supposed to be a gift, but I kept running into issues.

Check this thread for positioning errors:

We did everything on that list twice, but we can check it again.

It’s almost got to be something on that list. Maybe electrical noise. Can you post pictures of your setup showing positioning of electrical wires and placement of the power supply, etc.?

Is the 24 volt power supply plugged into the same 120 outlet as the router?

How would you characterize your knowledge/familiarity with electronics?

I documented my whole build process Here
The Router and the Power supply are plugged into a heavy duty surge protector. I am fairly proficient with electronics, especially constructing them from parts. I have built and repaired 10+ computers in the past 6 years.

Wow. What a great write up!

Since you have pretty much beat the mechanical side to death, let’s try electrical noise.

Here are two things you can try.

Unzip the power cord for the router and position it away from the drag chain (perpendicular if possible) and other electronics. You may have to baby sit the carve to make sure the power cord doesn’t get in the way.

Second thing - place a 100uF (50 VDC or greater) electrolytic capacitor across the power connections to the gShield as close to the gShield as is practical. Be sure to observe correct polarity on the electrolytic capacitor.


After I wrote that, we hung the router cable from the Cealing.

Do you have a video or diagram on what you want me to do with the capacitor?

I put some wiring insulation on the capacitor leads to prevent them from shorting to anything else. The postive lead on the capacitor goes on the gShield power connector with the red power wire from the 24 volt power supply. The negative lead on the capacitor goes to the gShield power connector that has the black ground wire from the 24 volt power supply.

If you are not comfortable doing this modification then don’t do it. It may not help, but it’s worth a try if you want to do it.

What are the settings on the current limit potentiometers? They should be somewhere between 11 and 12 o’clock if the dial is considered to be a clock face.

They are right around 12.

Try moving the X potentiometer back to about 11:30. If you are hitting the thermal shutdown, then that could cause you to lose steps and that would cause what you are seeing in the carve.

Okay. Tomorrow, I will also do another once over of the entire gantry, just to make 100% sure there are no issues there.

After an hour or so of adjusting the gantry and the X-Carriage, we even tried re-adding the stiffening mod. We have concluded it is a purely mechanical issue. We can push the carriage across the gantry and sometimes it will feel like it rides over railroad tracks.

Now, it appears to be working fine after doing all those steps, even with that issue I mentioned previously.

We are still having issues with the cutting depth. We believe set the right material thickness.

Thank You.

Ok, glad you got it working. Have fun.

We tracked down the cause, it started happening again today. The pulley set screws were coming loose and are almost stripped. We need to order a new set and a new pulley. Do you know where we can get longer set screws and should we use Thread locker on it?

Yes thread locker will help. I don’t know where to get longer set screws. Maybe McMaster or Home Depot?

Inventables is moving towards pulleys that are permanently on the stepper motors. The upside is this situation can’t happen. The downside is you can’t repurpose the motors for other applications later.