X Carve Homing Fails with Shielded Stepper Cables--Solved?

Been working with my xcarve for a few months now and it has been mostly doing a great job (aside from the learning curve). I have been seeing some lost steps mainly in the x axis, so decided to check my wiring and such (mechanical all seems fine and voltage pot seems fine). I never grounded my shielded wiring to the steppers so I decided to go ahead and solder a wire from the shielding and sheath to ground. My end stop wiring is all shielded and and the shielding itself is grounded.

Now I am seeing erratic errors when I home the machine. My wiring includes a small perfboard that has all the end stops soldered to it and a female header so I can easily remove it from the Gshield. I soldered the shielded stepper wire to the ground rail on my perfboard. The behavior is such that it seems that the end stops are getting triggered before they actually hit the home position. To verify that this is the case (it was the only change I made) I snipped the stepper ground cable leading to the arduino. Voila, my machine homes without issue once again.

Am I grounding this shielding incorrectly? Why is the grounding interfering with my end stops? (I am seeing this behavior with the spindle OFF-- have dewallt 611 and nema 23’s).


Update: Bypassed my perfboard and grounded directly into power supply. Now I am homing just fine. For whatever reason, the grounding was triggering the homing switch pins but now it seems to be functioning just fine. Solved?

So after making this connection I can say that my skipped steps are a thing of the past. I see many folks on here struggling with skipped steps and no obvious solution. If you haven’t done it yet, ground those shielded cables! Just did a two hour carve and my machine came right back to zero like it should, not even a millimeter off target. No stair stepping whatsoever! Its a wonder this is not part of the assembly instructions… hint hint…