X-carve not connecting

I finished my x-carve and plugged it into the wall and my comp. When I try to connect with easel it just says "Connecting to X-carve. Plug in your usb cable and turn on the machine."Im using a mac and I’ve tried chrome and safari. I’ve even tried a different computer. Im using the stock cable that came with the machine. Any guess on how i can fix this. Any help would be great! Thanks

Did you still have the machine set up window open (from the X Carve instructions) when you tried to use Easel?

What Mac OS are using? I connected immediately using Yosemite and Safari 8.0.7

When you switch the power on the XC does the blue light come on?

I’m using the newest operating system for my Mac and Safari and chrome done work

The blue light does go on

Before trying to open Easel, did you manage to connect to the XC in the “Machine Set Up” section of the installation instructions?

If so, did you close this window before trying to open Easel?

The only time my Mac didn’t link directly with the XC was when I had the machine set up window open also.

Easel is the only page open when I tried to connect

I’m having trouble too. It was working great for me, but now all of a sudden easel does not see my x-carve. Safari and Chrome do not work. The strange thing is that UGS (universal g-code sender) connects just fine and works great. So its not my computer. the only thing that I can think of that is different is that I am running mac OS X 10.11 and safari version 9.0… don’t know what the issue might be. Though chrome does not work either, so its no a safari issue. I contacted inventables, but they weren’t able to offer a solution.

10.11 the latest version of Mac OS X is still in beta and not recommended. It most likely will be fixed, but stick with non beta OS for now. 10.10

@LeviSheridan is this the same for you too? Are you running El Capitan or Yosemite?

I’m running the gold master release of 10.11, which will be made public on September 30th.

Yep, that is probably your issue. El Capitan doesn’t currently fully support connecting to the Arduino Uno.

So is it possible to downgrade my macs os? And if one should I downgrade too?

also im not using El Capitan I’m using OS X Yosemite 10.10.5

You cannot downgrade your OS, it’s not something you want to do or need to do, seeing as how you are running OSX Yosemite.

It is possible that there is an issue with the USB connection on the actual board, and in that case, you may need to get it replaced.
Good Luck.

Yep, @MichaelDelaney is right. Yosemite is what you want. It does seem like it is an issue with USB… maybe on the Arduino or gShield side of things.

Since you are running software and a machine that should work, I would recommend contacting support. Give them a call or at least email them. Check the bottom of this page here: https://inventables.desk.com

I am running Windows 7 and have a similar problem, on firefox it won’t let me pass the “Download for Windows” screen on ‘http://easel.inventables.com/setup’ but in Explorer passes this step and lets me select Machine, size, spindle, lead screw, etc. however it won’t continue and it is stuck in the “Connecting to X-Carve…Plug in your USB cable and turn on the machine.”. I downloaded the Arduino IDE, my PC recognizes the “Arduino Uno” and the blue LED along with the 3 green LED’s are on. I can move the axis with a GRBL controller so I don’t think the Arduino or the shield are “bad”.
Any ideas of what can be?

Sorry for reviving this old topic :frowning:

Did you need to pay for the Arduino IDE software?

No.