X-Carve Not Cutting Evenly - Overshooting - I've Tried Everything(?)

Hi all,

My X-Carve is not staying on track when carving and it seems to be overshooting the outline by about a millimeter with each consecutive pass.

For example, if I’m trying to cut out a square, the first pass looks great. Then upon the second pass (and all following passes) the X-Carve overshoots the outline on the Y and X by about a millimeter or so. This is happening even at painfully slow feed rates and shallow depths while cutting outside the line.


I’ve scoured the forum and tried as many fixes as I could find, including:

  • Checking/tightening set screws on steppers

  • Tightening all belts

  • Checking/adjusting eccentric nuts

  • Adjusting X and Y trimpots/voltage (as per RobertA_Rieke method)

  • Calibrating the steppers via Easel’s advanced machine setup (as per RobertA_Rieke method); FWIW I only needed to adjust the X calibration, the Y was right on but there was no change in result.

  • Checking square-ness of the spindle mount (the front X rail is tilted forward very slightly but I haven’t done DavidFletcher’s fix yet; hoping to avoid that as I’m just trying to build simple boxes and short on time).

Any help would be greatly appreciated. This is, of course, a dire emergency as I have a project due yesterday :wink:

question what program did you draw the box in ? and are you cutting on the line or inside or outside

How long have you been using this particular endmill?

Could it be that it’s no longer sharp?

You should keep a machine / tooling log.

I’ve tried generating the box in three different applications, all with the same result:

  • Adobe Illustrator (SVG export)
  • Easel
  • Easel’s Box Maker App (by Paul Kaplan)

I am cutting outside the line, which I’ve done before without issue.

The endmill has been used for an hour. I will try a new one now but the problem seems to be that the X-Carve is overshooting on the X & Y with each consecutive pass.

I just tried a new endmill with the same result.

I run fire fox for browser, and also start form the bottom left corner at one point I was starting from the center and kept having what I call run a ways

Thanks for the suggestions. I just tried with Firefox and Safari but the problem remains. I am also starting the carve from the bottom left corner.

Josh - this must be frustrating. If you DEFINITELY are sure your pulleys are not slipping (and many have been dead sure only to discover them slipping later), then you may be losing steps because the system is too tight. If you have Nema 17’s there might not be flat areas ground into the motor shafts so the pulley can still be slipping.

If I were you and you confidently tried all that you mentioned, I would turn off the power, loosen my belts enough to create a loop so my pulley is not engaged and make sure I could freely move in the x and y direction. One is likely WAY stiffer than the other. It should move freely, without the steppers interfering. I would loosen my v-wheels to the point where free movement is achieved, then re tighten my belts and try again.

why don’t you try to do a line let’s say 5" long with full 1/2 or 1/4 deep cut using a .250 end mill and do the same in the “y” and see if the slot grows, and if they do not then I would say something in your lay out is telling it to over size the pass

1 Like

That looks like loosing steps to me.

1 Like

Thanks for all the help everyone. I tried everything you suggested without luck. However, the problem is now solved. Long story short: It was a bad spindle. Inventables sent me a replacement and everything is working perfectly again. I was using the 24V Quiet Cut spindle that came with my X-Carve kit last year.

The long story:
I eventually noticed that the stepper motors where chugging (for lack of a better word) slightly while carving. It was hard to hear but they didn’t sound like they were running smoothly. I decided to turn off the spindle and run a test carve in the air. The steppers hummed along smoothly–no chugging. When I turned the spindle on during the carve, I heard the chugging again. So apparently this is the result of noise from a failing 24V Quiet Cut spindle interfering with the steppers. I dropped in the new spindle and everything is dandy–actually it’s carving better than ever thanks to all the fine tuning I did while troubleshooting.

I appreciate the help and thanks to Inventables for sending me a replacement spindle. Time for a DeWalt 611…

1 Like

Holy cow… all this time and you had the 24v spindle. Now THAT makes sense. I thought they were all extinct.

1 Like