X Carve not cutting to correct dimensions

Hello everyone, I’m new to the X-Carve and CNC. I recently purchased a used X-Carve machine with the upgrades. I have uploaded current firmware but my projects are cut a lot smaller than what I have designed. I’ve checked belts and rollers, and all seem to be good. When using firmware from the gentleman I purchased the machine from, the z- axis travels in the opposite direction. Can someone please educated me?

Got it figured out thanks to Fabiani at customer service.

Thank you

What was your solution???

I echo Braylon. I am having a similar issue.

Sorry I haven’t got back with you. I tried sending an email but would not go through. This is what coustomer service sent me and it worked.

Thanks.

Thank you for reaching out and I apologize for the trouble. More than likely, the incorrect machine components were selected in the Machine Setup. If you have the stock X-Carve and selected the z-axis drive and 9mm belts, your cuts will come out too shallow and undersized. The solution would be to go back through the machine setup and select the ACME threaded rod and 6mm belts: