Inventables Community Forum

X Carve Pro Stopping/Hold And BROKEN X-Axis under 10 hrs usage

I’ve attempted my current project 3 times. I thought my original problem was Easel, still not going back to that platform. Over the weekend, I spent a lot of time removing possible problems and I really believe the XCarve Pro is overheating and stopping or telling UGS to Hold.

I’m running my 1/4 Ball nose finish file after my 1/4 EM bit. I found that if I run at 125-140 in/min XCarve Pro skips chunks of gcode, which completely spoils the wood. I’ve slowed down to 80 in/min. Honestly a disappointing speed for a machine of this size and price. It now stops skipping chunks of gcode, however, it now randomly stops and must tell UGS to Hold. When it stops UGS displays Hold. If I wait 5 mins and restart it runs again. That was Saturday, which I’ll note was 65f around here. Sunday I ran the same file, 188,109 lines, and it stopped with 860 lines remaining. Sunday was in the 40f around here.

I’ve tested my finishing file with Aspire, there doesn’t seem to be any issues with the gcode.
I’ve done a clean reboot of my pc, only open UGS and run the file with XCarve Pro.
I ran task manager to watch the PCs resources. No issues noted.
All cables are stress free.

The only thing I can think of is it acts like it is over heating and pausing.
Anyone run into this and have any ideas?
For the money and size, so far I’m disappointed in the XCarve Pro performance. However, now I’m stuck. Not like I can go buy another expensive cnc. I’ll have to make due with this. So suggestions or ways to test that I haven’t thought of?

1 Like

I don’t have the XCP but on my other machines I’ve had an issue sounding identical to yours when I livestream my carve and the RAM peaks out. Then the sender fails to keep up with the carve as it completes lines of code and it’ll pause for a moment sometimes and then keep going again…
So maybe open task manager (which actually uses some ram itself too :man_facepalming:) and monitor that ram usage… of course running other programs on the same computer can further increase the issue…

Another thing to check is that your com port is set to the appropriate baud rate. You can check this in the device manager of the PC.

Just my 2 cents and it might be off the mark, but worth a shot to check :man_shrugging:

@SethCNC yes, good thoughts. I had resource manager open and watched everything. Didn’t notice anything that jumped out. I had all apps closed after a fresh reboot.

Good idea on the com, how do you know what baud rate for your Com? Is it listed somewhere in device manager?

1 Like

Well, I thought the last stop/hold was due to Overheating. Went to work on the XCP tonight and discovered the last stop/hold was due to a Broken X Axis

I bet I don’t even have 10 hours on this XCP. Wow, Broken X-Axis on a new X-Carve Pro on first project. I am majorly bummed about the quality of this machine…

So many Christmas projects are not going to get done.

How does one get ahold of anyone at Inventables outside of the forum. I tried the phone today and got a vmail.

1 Like

Oh snap!!

(OK it wasn’t that funny but I had to say it)

Email, attaxh that photo, I bet they’ll get to you with a quickness!!

Fixing that shaft would require replacing the whole stepper. I don’t know the specs on the XCP steppers or id just suggest sourcing a new stepper off amazon with possibly next day delivery… I got like 4 for $50 and keep the extras for spares on my cnc (not a XCPro) when one of mine failed after over a year of very heavy use…

If they will tell u, I would also ask what the power specs are and see if you can just get an extra off amazon a few days faster than inventavles shipping :man_shrugging:

Here is their “how to” page on that…

That is a really big bummer and probably a manufacturer defect from the stepper motor company. That belt should have completely been shredded of teeth prior the the shaft twisting apart.

Here are the Inventables’ employees on the Solutions Team of the forum (the rest of us are just regular forum members that help of our own volition); maybe this will get some attention!
@Ben-Saks
@Brandon_Cullum
@GiovannaDiazFabiani
@HenryPhu
@JeffTalbot
@KacperMarcisz
@LukeWilson1 - previously TBD CNC
@neilpa
@rodovich
@Zach_Kaplan

I am with Seth on the stopping/starting thing. It is likely not the XCP itself unless you do not have proper ventilation from the control cabinet. It is most likely something that was pointed out or some type of interference on the connection from the computer the XCP control cabinet.

{:0)

Brandon Parker

2 Likes

Sorry about this! Please reach out to use directly (help@inventables.com or 313-775-7009) so we can get someone working on this with you directly.

1 Like

Hi Brandon, thanks for making us aware. It certainly helps in a situation like this one. As @Brandon_Cullum mentioned, if @GregBuckwalter is able to reach out directly to our CS team they will be able to reply today. Everyone here at Inventables will work hard to get Greg back up and carving ASAP.

1 Like

Honestly, great job to @Inventables for the eagerness to help.

I personally run my machine up to 280 in/min feed rate. (Default @ 200% speed) and have never had an issue.

Personally, i’m happy to know it was a hardware failure, and not a bug in the code, as those are usually harder to diagnose.

@Brandon_Cullum I did call the number yesterday and got vmail.
I also sent an email, I received a reply from Zach. But no other email yet. The forum is great, but it is disappointing when you need some cs, there’s nothing there. I worked in cs before, it can run much better when promoting products for people to base businesses on. I will acknowledge Paul left me a voice mail this morning.

@SethCNC That big old 1 in diameter spindle has a quarter inch weak spot. I appreciate the attempt at humor but I’m still too pissed off to laugh. At this price point I’m very disappointed with the quality.

1 Like

@TCarter I expected those kinds of numbers when I upgraded but this break happened at 80 in per minute with a quarter inch ball nose doing 3/16 cut. I honestly think I could run faster on my old machine. I’m not completely sold that it’s not a overheating issue. I’ve got project would approve differently. Please note the broken X access was the last of multiple issues over the weekend with my machine. It arbitrarily stopped multiple times and skipped chunks of G-Code

I saw that we’ve had a few people working on your ticket. Let us know if your not hearing from anyone, I believe we already have a few parts coming to you right now.

@Brandon_Cullum Yes, I received emails and vmails from some of your team members. Also received notice that a replacement X-Axis gantry is on the way.

It has been brought to my attention that there was issues with early XCP’s x-axis. I was part of the early folks. I saw x-axis slipping in addition to skipping gcode blocks and simply stopping. All at speeds the XCP should be able to handle. I’m looking forward to working with your team members to resolve all the issues I’m experiencing.

Classic X-Axis slipping on first attempt during 1/4" ball nose finish cut. Go figure the 1/4 EM cut didn’t slip.

GCode Skipping on second attempt

GCode Skipping on third attempt. While I was trying to erase other gcode skips the x-axis broke.


.

@TCarter I really thought I could run at speeds like 280 in/min. Shoots I’d be happy with 180 in/min when doing finishing cuts, without issues. Hopefully when this gantry is fixed I can reach better speeds.

Not gonna lie, it’s a bit concerning, as I was one of the first shipments of the XCP. Luckily, I haven’t seen any issues yet, but its concerning that maybe i’ll run into something.

Luckily, I can easily knock on wood.

@TCarter under your X-Axis gantry on the left side is a model and serial number. Look that up. The folks at Inventables can tell you if your machine was one of the broken ones. If so, it will only be a matter of time. The x-axis belt tension was incorrect from the factory, nothing you did. Most likely mine had a crack when I got it. Was only a matter of time before it snapped.

I’d email those numbers to help@inventables.com

Keep knocking on wood :slight_smile:

Would verify the telephone help number 1 ost says 312 another 313 area code

@GregBuckwalter that’s super frustrating, I know as it happened to me as well. I had less than 2 hrs of carving when that same piece snapped. I will say, however, that the Customer service was top notch. They immediately got a replacement gantry queued up for me. Since installing the new gantry, I’ve had zero issues. I also upgraded from the x-carve 1000mm and this machine is far superior.

Be patient with them, and understand that, as one of the first to receive these machines, we have to expect some level of error as they launch a brand new product. It sucks that Christmas projects won’t get finished, but I can attest that they will get it taken care of.

Happy holidays

I believe Inventables sources all their steppers from Automation Technologies. I’ve ordered spindles and the like from them and they are pretty responsive. Might give them a try.