X-CARVE PRO Stops 20-30% through cut

Today my X-Carve Pro is stopping between 20-30% of the cut job. I am just planning the top of some wood. I am running Easel from a Windows 11 box. I have adjusted all the USB settings to make sure they aren’t going to sleep. I have tried a different USB port. I’ve rebooted the controller several times and the computer. I’ve updated the computer and the firmware of the device. I have even swapped the Windows computer with a MAC with the same result. Any ideas?

I started having the same issue yesterday after almost 10 months since the last time. I’ve grounded the whole dust collector system everywhere. I just turned off the dust collector while planing the spoil board and it never turned off.

I’ll have to give that a shot. I do hear a click so I wondered if it was a fuse or something?

I think I found the problem. Looks like it was a grounding issue.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.