Inventables Community Forum

X-Carve w\ X-Controller not calibrating (MAC)

I’m brand new here so forgive me if I ask many questions…I don’t know what I’m doing.

Just assembled a new X-carve 1000x1000 w\ X-controller & have an older MacBook Air plugged in.

  1. No power light on the X-controller (I’ve seen this seems to be a persistent issue for many)

  2. During the calibration/jogging process I’ve been able to intermittently get a twitch in all directions but not consistently. Not pressing any buttons now for about a half-hour but the Y-axis is still making a small adjustment on its own (lagging?) every ~20 seconds or so.

I’ve double checked that my wiring is tight on both the stepper motors & the controller.
I’ve taken the x-controller apart once to double check connections inside.
I’ve disconnected & reconnected the wiring from the stepper motors

I have noticed that the wiring on the X-axis & z-axis is backwards from the instructions, but the instructions also state that they can only be wired one way so it doesn’t seem that I can do much about that.

Please help, I want to start carving.

Thanks

What web browser are you using?
Inventables recommends using a Google Chrome web browser
I’m not sure about only being wired one way, 2 weeks ago someone had the X and Z wires plugged into the wrong stepper motors. But the machine was crashing into the side when she tried to home it.
Russell

I’ve only tried using Safari, can try with Chrome shortly.

When the directions state that the wires can only be put in “one way” I believe they are referring to the way the white wire clip can be inserted to the female receptor.

I’ll post 2 pics to show what I’m referring to - the first will be from the instructions, the second will be what I have.

I wonder if it is due to my macbook. System requirements state “at least 4GB of system memory” I have 2 on here…

So I’ve tried using a different computer with more system memory.
There is no lag but trying to set up homing just make a buzzing sound (like the motor is spinning) but nothing moves…

So my auto-calibrate won’t work (it gets stuck pulling the Z-axis up despite the stop). However I can manually calibrate it & it seems to work fine.

Stuck how?
During a homing sequence each axis trigger the switch twice, and if the pull-back distance after first tap is insufficient to clear the trigger, the controller detect an alarm state.

What are your GRBL parameters, please list them here.

It seems like the Z-axis keeps pulling up and makes a loud vibrating sound. The other axes do not move to calibrate.

GRBL parameters look good for Xcarve.
Grinding noise = stalled stepper = something is binding. Loosing the black delrin screw block, just so its baaaarely loose. Any luck?
Z-axis engage switch first, twice, then the other two axis will follow. You havent gotten that far yet.

My gawd… knew there was a reason I left this place… try enabling homing

4 Likes

Good catch Bob.

Set $22=1 and read the following for details:

How do I do that?
Do I have to take apart the whole spindle carriage to get at the correct screw you’re referring to?

Bob, I did make the adjustment to $22 with no change. Since it keeps trying to set zero with the Z-axis first and gets stuck, it never proceeds past that.

It seems as though the carriage is for some reason getting stuck before it hits either the stop screw or the probes. I’ll try to send a photo so you can see.

did you get your problems resolved?

Not yet.
I don’t know how to go about loosening the Z-axis screw as suggested.

Check and see if the Dewalt casing is obstructing travel.
The Z-axis screw is held down with two bolts, probably accessible from the backside of the gantry. Untighten them, let it ride a smidge loose just to check if there is a difference. If there is, only secure them snug, not overly tight as this may twist the screw block a little.

I tried loosening these a touch but it didn’t seem to make a difference…
Moving the router so I could get a better look it does look like a teeny part of the router body may have been obstructing the movement.

I tried going into the machine inspector and manually fired off the homing cycle ($h). It was able to then raise the body all the way up but then the router started moving to the back left corner of the table, got there then seemed to keep trying as if it didn’t know it was already there. The whole thing started kind of shaking and so I manually tuned the machine off to prevent damage.

Now what? :-\

Open Easel Machine Inspector Panel (press CMD+SHIFT+D) and press the switched manually and see if they turn green in the inspector interface, indicating contact.

If they dont, trouble shoot the switch/wires associated with them.