X-Controller (Help)

I just setup my new x-carve this weekend. The x-controller is not being my recognized by my laptop. I connected a windows 10 and windows 7 laptop and get the same error message. USB device has failed and not recognized. I have checked and double checked my wires. All seem correct. I have read through the forum and have downloaded (I think) all the drivers the FTDU USB driver, I downloaded the recommended arduino driver, Easel drivers .0.0.3 and 0.2.9. Under devices and printers it shows up as an unknown object and in device manager for Ports (COM & LPT) Nothing shows up and under the USB controllers it shows and unknown device. Browsers used Explorer and Firefox. Any recommendations.

Hi Brian,

I completed mine a week ago and had a similar problem. To cut a long story short it was the usb connection from the x controller to the pc. Remove the front plate under the stop button, remove the usb bulk head lead and plug a mini B usb cable direct into the board from the pc. I have now completed 5 carves without losing connection or the controller not being recognised. Inventables have confirmed they have had a number of complaints.
Good luck.

1 Like

Hi @ColinFarrant, Thank you for your response. I will try this and report back in awhile. Thanks, Brian

Hi @ColinFarrant,

 Thank you so much.  IT WORKED.   I spent  almost 5 hours trouble shooting

before posting for help. You think inventables would post this in their instructions. Now I am waiting on my waist board to arrive and I can start carving.

Again thanks,

Hey y’all! We have unfortunately had a few reports of bad USB bulkhead connectors, and our inventory receiving team is now testing each individual USB bulkhead connector in all X-Controller kits before they ship out. If anyone else is experiencing the same problem as the OP, please contact our Customer Success team and we’ll get you a replacement right away. Closing this thread down for now, and will update if any new information comes to light. Thanks!

1 Like