X controller not connecting

Hello. I recently got an x controller. First. Night it worked great with a test cut. Tonight not at all.

I can hear it click on then it’ll click right back off. I’ve retired everything, installed all programs again. Even when I use Grbl it says “has not finished booting”

I just don’t know what I could’ve done wrong from last night to now. I’ve also searched the forum but deals with Mac. I have a windows 10.

Thanks

I know I am having to restart my computer every time I connect to get my computer to recognize the X-Controller.

@CaseyMHart what version of the Easel driver do you have?

@SeanNaylor is it possible that some other program is trying to grab the port for the X-Controller?

Have you seen these support articles on the COM Port or this connectivity one or the FTDI driver.

Hey, Zach. It is EaselDriver_0.3.3

@CaseyMHart What about your computer and browser version?

Windows 10 version 1607
Google Chrome version 56.0.2924.87

  1. Have you tried manually connecting to the COM port instead of using the auto connect?

  2. Have you tried any of the earlier versions of the drivers? I don’t know if this will work but some of the earlier versions don’t have the auto connect which Windows 10 might be getting messed up on. http://easel.inventables.com/sender_versions

If you test this approach try and do it systematically one a time so you know which version worked.

  1. Have you tried another serial terminal like what comes with the Arduino IDE or Realterm to see if you can connect? If you can it is likely an Easel problem. If you can’t it might be a firmware or computer COM port issue.

  2. Does the COM port show up in Device Manager?

  3. Does Universal G Code Sender work?

So I don’t know if any of this is working I’m just getting sick and tired of wasting hours and hours this

  1. tried my wife’s Mac this is what I get

Then I reinstalled phil easel 2.7 on my computer, redone arduino ide 1.8 and the reflashed it with Grbl. Nothing is working

Universal g sender doesn’t work either. @Zach_Kaplan. I don’t know where to go

Looks like Inventables needs to start sending LarryM a paychek for fixing their issues. :slight_smile:

1 Like