Inventables Community Forum

X-Controller power light wont come on

I am sitting up my x carve through Easel but my x controller power light wont come on. The fan turns on, but not the light? Any help would be greatly appreciated!

2 Likes

Check your Estop.

It needs to be fully disengaged (turn and pull up) and also check the quality of the crimp.

The LED turns on if you have the Estop on.

The fan turns on as long as the power supply is on.

3 Likes

Estop wasn’t engaged…DUH! Thank you so much!

1 Like

Had the same issue, same problem. This should be added to the instructions…to ensure that the estop isnt depressed. its hard to tell if youve never used one before.

Same here. I agree with adding to the instructions.

I have the same problem, except my X-Controller otherwise works just fine. There’s just no power light regardless of the position of the e-stop or the power switch. I’ve been ignoring this for a year, but was hoping this thread would address my problem. Alas…

Make sure your ribbon cable between the front panel and main board is fully secured. Sometimes you think it’s fully engaged but it’s actually not. It’s a very common problem.

Thanks Justin, I’ll take a look when I get back to the shop.

Haha we’ve all been there!

1 Like

Hey Justin, I looked and checked and pushed all the wires in carefully and firmly. Still no joy. Any other ideas?

Check the actual connectors as there have been a batch which were overtrumped actually severing the connection inside the plastic covering, effectively hiding it from plain sight. A continuity check would verify electrical connection.

He’s not talking about the Estop, he just has no power LED indicator.

@ChristopherDahle try swapping ends of the cable between the front and main boards.

Hi Justin, Hi Haldor, thanks to both of you for the ideas. I hauled the offending machine along with it’s older brother (Arduino and G-Shield controlled) home for the Thanksgiving break to give them an overhaul. Then I decided that I needed to configure a couple of old laptops to run the X-Carves under Linux so the X-Controller is on the back burner again.

Too Much Information —> I’ve only got 3 computers in my school shop and when two students run the X-Carves, the rest of them have to share one computer to do their design projects. If I can get these old laptops to run Easel and drive the X-Carves, I’ll free the other computers up for student CAD work.

Anyway I do appreciate the help and just because the problem is low priority doesn’t mean I don’t want to fix it.

Cheers

Hey all. Total noob here. I am having this issue and have checked the e-stop button, removed the button, checked the wires and crimps, checked the ribbon cables, swapped the ribbon cables, rechecked ALL connections…still no power lights and not connecting to Easel. Any help would be appreciated, I really hope this is something that I have overlooked. I have been anxiously waiting to make some sawdust with this. Thanks!

Do you have a multimeter on hand, to check if the power supply work or trace where power stop?

I do not have a multimeter but it is on my list to get now. I just put this together and this was the first time I had powered the machine up…and nothing. I’ve spent hours reading the forums and checking facebook for answers. Now I am waiting to hear from Inventables.
Thanks for the reply.

@RodMacdonald did you ever get an answer or figured out what the issue was? I recently bought a new 1000mm x-carve with x-controller. unfortunately I’m overseas right now and had it shipped to the girlie back home. she got everything assembled and upon powerup and attempted setup she gets the power supply fan on, but no lights on front panel or back and cannot connect to easel on her MacBook Pro. Her pops in an electrician and tested the e-stop and power in and out from power supply and says they’re good. Just looking for anything else to try while she’s waiting to hear from support.

Hey Daniel.
Yes this issue ended up being the USB board was not soldered correctly. The small cable inside the x-controller was putting pressure on the connection and it actually popped off the board while I was on the phone with customer service. Seems like they must have gotten a bad batch of these boards because I have been seeing a lot more of these issues on the forum. Customer service was great, they walked me through a bunch of trouble shooting prior to that and were super fast at getting me the replacement parts shipped out. I was up and running in 2 days.