X-controller Y-axis reversed in Easel

Just finished upgrading my X-carve V1 to X-carve V2 and almost everything seems to be working properly. But I’ve got two problems.

  1. When starting a carve, after confirming the home position, the machine seems to move in the negative Y direction rather than the positive Y direction with respect to the origin in Easel. Wondering how to fix that? Can I just reverse the wiring for both Y steppers? Maybe use a GRBL command somehow?

  2. The power LED on the X-controller doesn’t come on. This seems odd since everything else seems to work.

This is not an issue of jogging. The issue is that Easel sees the origin at 0,0 (X,Y) and tries to do the whole carve in the -Y direction instead of the +Y. Or to say that another way, if I home the machine at the bottom left corner of the workspace, the carriage repeatedly slams into the Y-limit as it tries to do the carve off the bottom edge of the wasteboard.

Of course, if I move the home position to the middle (Y-axis) of the wasteboard, then the carve proceeds just fine without hitting any limit at the bottom edge. But we all know this isn’t the way the machine should work.

Found the answer to my problem at: https://github.com/grbl/grbl/wiki/Configuring-Grbl-v0.9

The command $3=1 fixed it in the advanced machine settings.

Now I just need to figure out why the power LED isn’t working.

Most likely you have an internal X-controller cable that is not fully seated on its connector.

FWIW, I don’t have automatic homing enabled. (My limit switches are broken.) So I have to manually set the origin at the begining of each carve.

Sounds exactly like your wires are backwards into your stepper motors, but good you have a solution.

LED problem - I’ve just built my X-Controller, and the front panel LED is shot. I replaced it (with a red one just to be different) and the new one works fine. The original had a cracked body, which I can only assume happened during factory assembly of the board.