X-Crave 500mm x 500mm using Easel Problem

Hi there.
I have purchased 500mm × 500mm x-crave from inventables and using gshield v5 interface with Arduino Uno.I have uploaded the grbl v0.9j on my arduino and using the software easel crave.The problem I am facing is that my machine is not able to detect the homing position.While checking up with my hardware the x, y and z axis is correctly working and even my homing switch on x,y and z axis are working.
*As i start craving, the x axis starts to to the y2 axis rail so hard and start vibrating.I am using manually control spindle.I need help in this

How are you setting your work zero?
Can you send $# through the machine inspector and paste the results here.

This how I am setting my work zero using grbl v0.9j

$# Code is

Where are you homing as in bottom left or centre of your work. If your setting zero in centre of your work then placing the spindle at 0 0 0 it will try go beyond the limits.

We need clarification.
Do Y1 and Y2 move same direction relative to travel - or is one reversed?
What actually start vibrating? (grinding noise?)

Y1 and Y2 moves in the same direction.
When I home the position on the easel software and further process it to it crave it well it doesnt crave as the x-axis moves away from the material and start hitting the y rail and start vibrating, due to that i had to forced stop my x-crave.I dont why this is happening.I am not using the z probe

Are you working in mm or inches? Maybe posting the first few lines of you gcode will help diagnose the problem.

We need to establish the step/mm is correct (or as @MichaelColey mention a mm vs inch issue)

When you command a 50mm jog is the travel also 50mm?
Also please share your Easel file :slight_smile:

Working in inches @MichaelColey, My X, Y and Z axis works well while setting up the machine on easel. Even my limit switch on x,y and z works well while doing the test.Only problem is that it does not crave and after setting the homing position as said earlier. It goes on hitting the rails and vibrates the machine which make the machine to force stop. Below is my gcode for 500mm x 500mm using easel


For now focus on setting up the homing correctly:
Check specifly GRBL parameter $23 and the loaction of your homing switches.

Also note that with Easel “Home Position” (Work Zero) and “Homing” (Machine Zero) are two very different things.

@HaldorLonningdal for easel Home Position ‘Work Zero’ how can we relate this to grbl code.While doing changes to $23 will there be changes with it?

I am homing it at the bottom left

Unrelated, dont spend time on that.
Value of $23 dont have effect on work zero.

$23 define where Machine Zero is at, a common point is Z up / X left / Y away (Upper left corner)

Work Zero can be anywhere within the range of the machine. You need to match the design with your work space.
I think you have a mismatch here.

Open up the following Easel file:

  • Perform a Homing Cycle
  • Jog to the closest left corner 20mm above the waste board
  • Use this point as work zero (Easel Home Position)
  • Do a carve (in the air, no material)

When the carve actually begin, is the first motion (in XY direction) in the away/right direction?

What else software can we use to make work more easier for X-Crave using ghield & arduino (grbl v0.9j).

Stick with Easel untill you have the mechanical issues sorted / established a good workflow and are confident.
Then, based on what you may want to achieve, can we suggest a different approach.

Easel isnt the issue here and as far as CAD->CAM->CNC goes Easel is as easy as it gets.

When I home the machine then this is my position:

When I crave it as you stated…
This is where machine goes and is not moving smoothly

Can help me out on steps/mm…I think there is a problem with the coding if we using NEMA 23 stepper motors…As its not able to detect how steps/mm or steps/revolution it should work…

Someone else correct me if I’m wrong here…

I notice in your GRBL settings that both $100 and $101 are 250… I think they’re supposed to be MUCH lower. Try setting them both to 40, then try a test carve.

1 Like

Yes, default is 40steps per mm so travel is exaggregated by a factor of 5 most likely. The rest of the parameters are also way off relative to Xcarve defaults.

But getting the step pr mm correct is primary goal now, the rest will be sorted/easier to debug when that is done.

How to edit a GRBL $ parameter:
Press CTRL+SHIFT+D to open up Machine Inspector. (also accesible via Easel meny)
In the Console window simply type $100=40 and click Enter. Do the same for $101. Reset system and try the test carve again.

Here is more on the topic:

Once steps/mm is sorted the $110-112 and $120-122 values need to be changed too. A starting point: