X Limit issues, Can anyone help?

My new X carve 1000 x 1000 mm is not homing correctly. The z and y limit switches work fine. However when the spindle moves to find X limit, it moves back instead of forward hitting the back rail. what did i do wrong?

You mean Y? Forward and back.
If so, power off and swap Y1 and Y2 connectors at the controller.

1 Like

sorry, yes y… i tried switching y1 and y2 but it does the same thing

It still moves back?
Swapping the motor connections should reverse the direction.

Try going through the Easel computer set up again. If the direction is wrong, it should change the value in GRBL.

You could also do it with a change in $3 I believe.

Grbl v1.1 Configuration · gnea/grbl Wiki · GitHub

$3 – Direction port invert, mask

This setting inverts the direction signal for each axis. By default, Grbl assumes that the axes move in a positive direction when the direction pin signal is low, and a negative direction when the pin is high. Often, axes don’t move this way with some machines. This setting will invert the direction pin signal for those axes that move the opposite way.

1 Like