Xcarve not respecting home position

I’m running vcarve pro with UGS. In vcarve, I make sure my zero position is in the lower left hand corner. I zero the machine on the lower left corner of the workpiece. I then set that position to zero in UGS. I close UGS, reopen it, and machine zero and work are now both at 0,0,0. I visualize the cut in UGS and confirm in the image that the bit is at the lower left hand position. Start the router, send the gcode, and the xcarve immediately moves to the left of my 0,0,0 position and starts to cut air. What am I doing wrong here?

Home sequence for only X and Y position. Are you running Z zero manually. Put Z Zero on search engine (Top right corner) if you’re not.

I did some searching and haven’t come across anybody else with this problem. Maybe I’m not using the correct terminology. I’m zeroing the all x, y, and x axis manually. I’m not using a touch plate or homing switches.

Did you just set up your X-Carve? Any chance some wires are crossed?

When you power on your electronics, grbl has no idea where your spindle is actually located. Since you don’t home the machine, wherever the spindle is located when power is applied becomes Machine 0,0,0.

Homing is used to get the spindle to a known location and then set Machine 0,0,0… Gives a good, repeatable reference point for the software to sync to the hardware.

When you use UGS to Zero the axes, that only zeros Work Zero and does not affect Machine Zero.

So, to get what you seem to be doing all matched up you would:

  1. power on the machine (Arduino by USB, and the 24 volt power supply)
  2. jog the machine to where you want Machine 0,0,0 to be
  3. turn off the electronics (unplug the USB cable)
  4. turn the electronics back on and hope that the off/on cycle hasn’t moved the spindle
  5. jog to where you want Work Zero to be and zero the axes in UGS
  6. run your job

I’ll give this a try. I’ve been using vcarve with ugs for a while now and haven’t seen this problem. Odd that it is occurring now.

Yeah, I’m scratching my head over this one. I took a look at the V-carve PP and didn’t see anything in there that might be causing trouble.

Check your stepper motor wires to see if anything has come loose.

I’ve been playing a little and I don’t think my earlier comment is going to help. I think it’s something else.

I had this issue when using Fusion 360.
Make sure there are no G28 codes being generated.
These codes tell the machine to move to a predefined location.
V-Carve may be assuming you are using them for tool changes.
For now, try to take out these codes.

If you get clever you can use the tool change location and ChiliPeppr to take advantage of it later.

In UGS, type $$ in the console and make sure $3 is set to 00000011. This sets the Direction Port Invert Mask.

When you tell the machine to go somewhere, you feed it coordinates. The $3 value defines which direction that ACTUALLY is. So if your spindle is at 0,0 and you tell it " go to X4 Y4" it needs to know whether you mean left or right for the X and back or forth for the Y. Some machines are meant to have their 0,0 point somewhere other than the bottom left corner, and the $3 setting is what allows for this.

Here’s a site that explains it better than I can:

Be careful with this change. Depending on the way it’s wired, some machines use $3=0 and others use $3=3.

Since the machine was working, this is probably not the problem.

It could be worth looking at the $$ config anyway, just to make sure that there’s nothing hinky. I’ve had GrblController for linux overwrite config settings without me knowing, and I was sitting there going “Why is my machine sounding so bad and moving all notchy?” I went down a hardware rabbit hole, checking belts, eccentric nuts, V wheels, stepper pots, wiring connections… everything. It all checked out. Then I double checked my $$ config and noticed that $11 and $12 were WAY out of whack. Another time it enabled $21 - hard limits. Every time the spindle turned on, electrical noise from it caused a false-positive on the homing switch and threw an alarm on the machine.

I know the plural of anecdote is not data. However, I’ve been burned enough that when my machine is acting fishy, the first thing I do is double check $$ just to be sure.

Yep, good idea.

My first thought lies with vcarve and not the machine.

Double check you material setups in vcarve to make sure you are not running any sort of offsets.

The simple little circles with the red fill-ins can make a person wonky if overlooked.

I looked over vcarve again and noticed I had a vector to the left of the my 0,0,0 location. Problem solved. Thanks for the help everyone.

Great news, Paul. Good luck with your carving.