Xcontroller and Laser

How can I reset the Xcontroller back to factory settings. I tried to install LightBurn and can’t get it work. Now in Pic sender laser mode, the Xcarve runs in the opposite direction.

The direction of movement is altered with the $3 setting.

You need to read the current value and then adjust per the chart.
For Example, you cnc is running X backwards and is currently set to $3=3
You would select the option that only changes the X value, but keeps the Y and Z the same. The New Value to use is $3=2


Thanks Seth. Where do I find the table that you referenced?

I added the chart as a photo (maybe its not showing on your device), but here it is as text:
& for this purpose you can ignore the “Mask” column :+1:

Setting Value Mask Invert X Invert Y Invert Z
0 00000000 N N N
1 00000001 Y N N
2 00000010 N Y N
3 00000011 Y Y N
4 00000100 N N Y
5 00000101 Y N Y
6 00000110 N Y Y
7 00000111 Y Y Y

and a link to the grbl settings github page where it’s also posted:Grbl v1.1 Configuration · gnea/grbl Wiki · GitHub

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.