Y-Axis Gantry Motors Whining

Ok, I have a feeling this isn’t going to end inexpensively… lol.

I have a fully loaded 1000mm x-carve. It has run great for several months now. About a month ago I finally got the machine level and everything tightened up again and cleaned. I also tweaked the voltage on the controller to all of the motors though they ended up very close to where they started, if not in the same place.

I let the machine sit for a few weeks and come back to start a project when I turned it on it is making a whining noise. The motors also we’re grinding as if I were holding the gantry in place while I tried to advance it with the arrow keys in Easel. So I got down to the GRBL shield and adjusted the voltage down. (All that did was change the pitch of the noise.) So after about 20 min of checking connections and trying to run the machine the noise mysteriously went away! and I ran a job and it worked perfectly. So I shut it down and walked away.

A week later I tried again… NO NOISE still! Hooray! Ran another test. Shut it off and cleaned my shop.

So then I went to actually cut another job for a client… THE NOISE WAS BACK!

Here are a few other details that I left out:

  • The first time I heard the noise my shop had been in the 30’s a few nights.
  • When I unplug the USB from the computer or the controller the noise stops.
  • When I cut the job that first day the motors sounded a little different but not the same whining, struggling, grinding noise.

Here is a link to the sound they are making: https://www.youtube.com/watch?v=XvDPG1lanxU

I’m fine with buying new motors I just want to make sure its not the controller before I order two new NEMA 23’s.

That is so weird, that it is coming and going. I would think that if it was a bad connection or bad controller it would not work all. :confused:

“When I unplug the USB from the computer or the controller the noise stops.”
On mine I notice that when I unplug the USB it stops sending power to the steppers. I can hear them “thunk” when I plug the USB in and they power up.

“The first time I heard the noise my shop had been in the 30’s a few nights.”
That makes me wonder if it is temperature related? That it starts working as it warms up?
I am guessing that it is either a loose connection or a bad g-shield? (I don’t think both steppers would go bad at the same time.)
I would try reseating your g-shield (just in case a pin isn’t making good connection) and then redo all the wires on the Y axis. Remove and reseat them, just in case there is a connection issue you can’t see.

Let us known how it works out.

So I finally got to rewire the Grbl shield to see if it was a motor prob or not. It seems that it is in the Grbl bc any motor that is wired to that terminal whines. I tried emailing support last week and they never responded so I just emailed again to see if there is anything they can do.