Y axis not working, not binding, maybe sheild problem?

X is fine, Z is fine, Y is dead, but won’t bind up when there’s power so I’m assuming there’s no power getting to the motors. The wiring all looks good and the machine was working earlier today.

The green lights for the X and Z motors on the g shield light up when they are activated but the light for the Y axis motors doesn’t light up. Should I assume something fried on the g-shield?

Thanks for the reply. Went over the wires a few times. Looks good. Didn’t do any two-step carves. Just used Easel for some simple signage. Went into the machine setup in Easel and X and Z worked fine, little green lights on the gshield went on when the motors were activated. When I tried to force the X to move with my hand, it locked as expected. But the Y wouldn’t respond in the machine setup. Nothing lit up on the board and when I pushed the carriage with my hand, it slid as though the machine were off. So I guess there is no power getting to the motors. That’s as much as I’ve got at the moment. When I first got the machine, I had a similar problem with the X and it turned out to be the shield. (Inventables sent me another one.) But could it be something else? Ideas on things to check?

At the gShield (with the power off) swap the X wires to the Y connector and the Y wires to the X connector. Turn things back on and see which axis works and which one doesn’t.


Right. Great idea. Will give that a shot…

Get a good continuity tester. Check the crimp connections. (No power… turn everything off)
The wires going to the motor should have solid connections.
The motors can be checked as they will show a small reading on any DVM meter.
As said before check carefully each connection and the wires. Make sure nothing is connected to the wrong place.

Swapped the motors and it was the same. Whichever motor was connected to Y didn’t work. Just to make sure the problem is the shield, I flashed another arduino uno that I had lying around. I still had the same problem.

I have a number of other motor shields but they only allow for two stepper motors. Guess I need a new shield.

I did. Didn’t work. But thanks for your suggestions. It’s great to have such helpful people on this forum.

1 Like