Y Axis Problems

Hey guys

Would really appreciate your help here.

I’ve set up my X-Carve and now going through the ‘Test Your Wiring’ calibration step.

When I jog the Z and X axis they work fine.

But no matter which arrow I hit for the Y Axis, the machine jogs forward. Both arrows work, but they both make the machine move in a forwards direction.

Any thoughts?

I’ve check the wiring. I’m pretty sure it’s exactly as it should be. Are they are any other potential reasons for this to happen?

Thanks in advance!

Just as a test:

At the X-Controller terminal blocks:

Disconnect both Y motor’s wiring.

Wire the X motor to Y1.
Wire one of the Y motors to X

Run setup again and test the axis ( which axis doesn’t work right X or Y)?

If that works ok move the X motor to Y2 and try again.
Which axis fails X or Y?

Sounds more like incorrect wiring no?

Make sure your wiring is right for each Y motor. You switch it on one of them so they don’t work against each other.

He said:

Right, I mentioned it in case it was similar to what I ran into. I had the wire incorrect initially and it moved forward each time (even tho the other side was going against it) regardless how I jogged it. It may have been a fluke because I quickly checked the wiring once I noticed something fishy but figured it was worth a mention in case it is that simple. :hugs:


Fair enough, i never faced that issue.

I remember Philip or someone having boths Ys wired the same and it only move one direction.
I am with Phillip Danner on this one as well.

1 Like

Hi guys.

I’ve been away on holiday these past two weeks. So just coming back to this. I appreciate all your input.

@PhillipDanner I’ve just followed the setup as it is in the videos. I did notice that the narrator in these videos mentions switching them, but then he proceeds to wire them in the same order - red, blue, green, black. The wiring diagram shows the same. Am I missing something?

@LarryM - I’m using a pre-August-2016 model, so it’s not the X-controller. But guessing I can do a similar test with the Arduino/gShield? I’ll check it out.

UPDATE: I just in another forum post that you’re supposed to flip the black and green on one of the Y motors. This is not in the diagram or the video. But maybe this is what I’m supposed to do?

I’ll give it a try…

Nope. That didn’t work. They move in opposite directions now. But they move in opposite directions no matter which of the Y arrows I press. So still the same problem.

Something’s not right here.

Sounds like they are hardwired to run opposite, so regardless which Y-direction you press they will run opposite to eachother.
I assume they dont travel in one (1) direction only when you press Y+/Y-.

On one of the Y-motors only, swap over one (any) of the wire pairs to reverse rotation of THAT motor.

@HaldorLonningdal thanks for your response.

This discussion could get a bit confusing, so let me clarify:

What I mean by “opposite directions” in the above comment was they they move in opposite directions on the rail. Which in fact means that the motors are turning in the same direction - i.e. they have the same polarity.

This only happened when I swapped the black and green over as suggested on one of the Y-motors.

Before that - and the original reason for my post - is they they only travel in one (1) on the rail when wired up according to the diagram. So no matter whether I press Y+ or Y- they move to Y+.

In this scenario the motors are turning in opposite directions as they should. i.e. their polarity is correct. But their movement on the rail is only ever Y+ (forwards).

Hope that makes sense.

*“in one (1) direction” is what I meant to say in the 4th paragraph

Okay, so status quo is that the gantry move away from you (Y+) only and if attempting to jog opposite direction it still go toward Y+?

What happens if you disable Y2 and run Y1 only, and then Y2 only?

The symtoms you describe sounds like a bad controller if I understood it correctly.
Or one of the 4 main motor wires (before Y1/Y2 connect) have a broken connection. But then direction should be random, not only one way.

Yes the status you described is correct. The gantry will only move in one direction, no matter which direction I jog it.

Yes, I think it must be a problem with the control box - with the signal it’s giving out surely? It’s only giving out one type of signal, and not the opposite.

I’ve tried re-reflashing the firmware also. No affect.


No. It’s an older model. So it’s Arduino+GShield

Have you tried cleaning the two boards and re-seat them?

I had the same thought. No affect :frowning: