Y-axis stopped moving

hi all,

the y-axis on my x-carve stopped working. it worked fine on my last project (finished today) but now it will not move. the y-axis motors are powered and x and z are fine. i disconnected one of the y-axis connections on the x-controller and swapped the other one with the x-axis. y-axis motors (at least on one side) are fine.

anyone any idea where to start looking inside the x-controller?


If the Y-axis suddenly stopped (two motors on Y no?) then there is a problem within the power to the stepper drivers or the signal to them. Go over all connections, make sure they are seated fully.

yes, 2 motors. both motors are hold/locked in place by the x-controller but do no movement.

all connectors are (re)seated well

must be a common signal from the micro-controller to the motor drivers? guess something on the controller board gave?

anyone experienced something similar (and fixed it?!)


I’m having the same problem.
I can change the wiring from the z axis to the y axis and it will move y axis fine,but not when the y axis wires are connected.
Does anyone know what the issue might be?

i got a new pcb from inventables and all worked again…