Y Homing Switch

During initial homing sequence, the Z and X homing switches worked fine, but the Y switch did not stop machine travel. I called Inventables and they recommended trying a different limit switch, sent a new one and it did not work either. I verified by opening the Machine Inspector (green light vs. white). To evaluate the wiring, I then plugged the Y limit switch wire train into the port for the X limit switch on the control box. It turned green, so I know the wire is working okay. I’m not sure what to try next. I called and left a message with Inventables.

Sounds like your issue is internal to the xcontroller… there’s a ribbon cable inside that could be disconnected.

Here’s some more info and photos of the inside on n the xcontroller
https://x-carve-instructions.inventables.com/upgrade/step3/1assembly/

Did you trouble shoot it with the X ?? another word unplug X and check Y. it could be the female connector or just loose wire. try crimping the connector on the micro switch (don’t do off the micro switch you might not get it back on), or better yet solder it (that’s what I’ve done).

I secured all the wires inside and outside of control box. Still won’t activate Y limit switch. I tried different switch and wires and they also didn’t work.

1 Like

did you try easel setup? go to machine General setting machine inspector,
check your setting: these are the default setting.

(ALSO: try pull your homing wire off the controller depress the switch and check for continuity)

last of all how about some pictures switch and wire lead hook up.

$3 = 3 (dir port invert mask:00000011)
$4 = 0 (step enable invert, bool)
$5 = 0 (limit pins invert, bool)
$6 = 0 (probe pin invert, bool)
$10 = 115 (status report mask:01110011)
$11 = 0.020 (junction deviation, mm)
$12 = 0.002 (arc tolerance, mm)
$13 = 0 (report inches, bool)
$20 = 1 (soft limits, bool)
$21 = 0 (hard limits, bool)
$22 = 1 (homing cycle, bool)
$23 = 3 (homing dir invert mask:00000011)
$24 = 25.000 (homing feed, mm/min)
$25 = 750.000 (homing seek, mm/min)
$26 = 250 (homing debounce, msec)
$27 = 1.000 (homing pull-off, mm)
$30 = 1. (rpm max)
$31 = 0. (rpm min)
$100 = 40.054 (x, step/mm)
$101 = 40.054 (y, step/mm)
$102 = 188.443 (z, step/mm)
$110 = 8000.000 (x max rate, mm/min)
$111 = 8000.000 (y max rate, mm/min)
$112 = 500.000 (z max rate, mm/min)
$120 = 500.000 (x accel, mm/sec^2)
$121 = 500.000 (y accel, mm/sec^2)
$122 = 50.000 (z accel, mm/sec^2)
$130 = 790.000 (x max travel, mm)
$131 = 790.000 (y max travel, mm)
$132 = 100.000 (z max travel, mm)

Those are actually the pre nov2021 xcarve settings and since the OP said this:

Along with the date the OP joined this forum, its quite likely that this is a post nov2021 machine which means that many of those settings are actually inaccurate for their machine defaults. :man_shrugging:

maybe misty can provide information which unit she has.

Yes it is post Nov 2021… inventables believes it is a problem with circuit board. Will find out in a couple days

1 Like

Well, I received a new power supply circuit board, as shown in picture above. Installed it without changing anything else. Now the Y limit switch works fine but the Z switch will not work. Ugh

1 Like

Just the switch itself or the same issue with internal connection on the xcontroler?

I accidentally loosened a wire on the z axis limit switch plug as I was installing the new board. I tightened it and all is well. Thanks so much for your help on this.

1 Like