Inventables Community Forum

Z - Axis acceration and speed tunning from Easel?

Hi Guys,

Is there anywhere I could change the configuration on my carvey via easel to reduce the accelation rate?

Previously facing some issue with the Z-axis error, I have check the smart clamp , pully and belt and the stepper motor. My only hope now is try to change the accceration rate and max speed to see if its making any improvement. is it $102 and $122 ?

Many thanks !

Don’t change $102, that’s the steps/mm.
You want $112 (rapid rate) and $122 (acceleration).

Is there any up/down play in the Z?

Hey Neil ,

Its you again :slight_smile: . So glad to see you.

Its still the same issue, but what happen now is I dont have much of a initial error , but most of my craving is 10% too deep.

Was thinking to replace the belt and stepper motor but pretty much all shops are telling me that highly unlikely is the problem with the stepper motor and my belt is still looking good.

Is there any way i can reduce the acceleration ? quite new to the easel.

In the console, send $$ - this will display all of you’re settings.
When you want to change a setting, say $112, just send the new value like this:
$112 = 1000

It’ll reply ok

If you want to double check that the changes worked, send $$ again.

Who’s telling you that? Inventables? They are right…just curious.

There are a couple things that can get loose on the Z, though. That’s why I ased if you have any play in the axis? Can you push the spindle up or down at all?

Previously the spindle and frame was abit losse, so i tighthen it up. Not inventabes, but few local 3D printer and CMC parts supplier. to get to the console just Ctrl Shift D right ? We are actually a school , so wondering if this changes has to done for every single account ?

Yup.

Me too.

Nope, it’s persistent on the machine, not the computers.

Hi Neil,

My console doesnt seems to be changing the number.

Also somehow after I take everything apart and check the pulley , belt and stepper motor, now my error gone from 10% too deep into 10% not deep enough.

Any idea ??? This thing is starting to get on my nerves XD

image

dont worry , managed to change the setting , but not making any improvement :frowning:

Just saw this. So, what, exactly is the symptom you’re seeing?

Previously the cut was too deep, now the cut is not deep enough and 10% error on average.

I placed 6 hole next to each other from 0.5mm , 1mm, 2mm, 3mm, 4mm, 5mm.

When the Depth per press was set on 0.5mm , i can see the first hole which required only 1 press got only 0.2mm depth. (doesn’t matter whatever value on $112 or $122.)

I then changed the press into 0.25mm, then i got initial hole for 0.6mm (which is not bad ) but then on the last few hole are still 10% less deep.

Initially I was thinking problem might be the stepper motor is not getting enough current to rotate back up if it spin too fast , hence I decided to change the acceleration. but seems like back to square 1.

If you jog the Z, does it move the exact amount you tell it?

Can you run that step test again?

That would typically make the cuts too deep. The machine would lose steps on the rapid retract and then plunge too far.

What endmill are you using?

1/8 straight cut. Do you mind to explain what’s the step/mm meaning on $102?

That’s why I asked:

Basically, the controller sends pulses to the stepper motor. The $102 setting tells it how many of those to send for every mm of travel. You usually don’t have to mess with it on screw driven axes, like the Carvey’s Z-axis. There is a belt driving that axes, though, and it’s tension or stresses may affect that value.

Try jogging the Z 20mm.
Measure, as precisely as you can, the actual travel.

How do i jog the z axis ? i only cna control it on Easel, I dont have a controller for that.

I believe something to do wit the belt tension as well since I took it apart and reassemble it then it has gone from too deep into not deep enough.

I did try to change it from $102=350 into $102=355 and $102=352 and run test. 352 seems to be reduced the error down into 5% . Not sure if that will be the solution.

once again, thanks alot for helping !

I don’t use Easel, but can’t you see this?
image

Ok, Thanks, I’m running it on Windows 7 and i think this features only available on Windoes 10.

Will update it and test it again,. lets suppose it i Jog it to 20mm and if i measured it is 19.5mm, how can i adjust it ?

If $102 = 350:
20mm/19.5mm = 1.026
1.026 * 350 = 359.1

$102 = 359.1

Test again, and dial it in. The more precision and accuracy the better.

1 Like

When calilbrating also jog the larger distance possible, because the error % will be lower.