Z-axis doesn't cut deep enough

Hey guys. I just upgraded my X-carve 1000mm with the new upgrade kit, containing the X-controller and all the other good stuff. My machine worked flawless before the upgrade, but now the Z-axis doesn’t cut deep enough at all.

If I set the distance to 10mm in Easel, it travels approximately 2mm in the Z-axis. The X and Y-axis work flawless. I have configured the Z-axis as a ACME rod, and tried to configure it as a M8 instead, however without that working correct either.

My machine inspector looks something like this:

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=115 (status report mask:01110011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$30=1. (rpm max)
$31=0. (rpm min)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=790.000 (x max travel, mm)
$131=790.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

What am I doing wrong? I have tried the Easel configuration many times, however it doesn’t change anything. I hope some of you knows what to do :slight_smile:


Sound like the microstep settings of your Z axis is off.
These are the small white switches in the red housings ion your controller board.

This picture comes from the Inventables website.

1 Like

Thank you! You are completly right… I hadn’t thought of that :slight_smile:! I changed the Z-axis to a micro step value of 1/2 and kept the X- and Y-axis with 1/8. Now it seems to be moving correctly. I will have to make a few measurements to be sure, but it looks good! Thanks a lot :smile: