Inventables Community Forum

Z axis fault

Hi everyone.

I think this request is in wrong place so sorry about that am new to all this
My request is, is there anyone out there who can tell me why when I home the z axis before I hit carve on my 3018 and then click on raise bit the z zxis moves all the way to the top and stays there. It used to work correctly.
It then starts to work normally as though it is contact with the material.

Once again if this is in the wrong place I apologise but am not computer literate.

Best regards Stuart and stay safe

I’m not sure what “normal” is for a 3018, but it sounds like your work z=0 position is getting set up in the air above your work piece somehow.

Keep in mind that “machine zero” and “work zero” are different, though related, positions. Machine zero refers to the reference point for your machine’s physical operating area, and is set during the homing procedure. Work zero is the reference point for your work piece, and is established as a point relative to machine zero (this is the point set when clicking “Set X/Y = 0” and “Set Z = 0” buttons in software). If you ever lose power during a carve, the idea is that you can leave your setup as-is, re-home the machine (re-establish the machine zero point), and your work zero point will still be in the same place (so you can salvage your work).

Unfortunately, the term “home” is used somewhat ubiquitously in this context - some people use it to refer to machine zero, and some use it to refer to work zero.

Hi thanks for that but how do I put it right.

Stuart

use the jog control to make sure the axis is moving in the correct direction. up arrow moves the Z axis towards the top, down arrow moves the Z axis towards the project (bed) .

If this is still correct then make sure that when you home the machine to the work zero that you place all axis on the work piece as desired (work zero) the set work zero in the program.

if all that is correct then start checking for loose connections on your controller and axis motors.

Hi Kenneth

Thanks for that sorry for the delay in answering you. Its getting more complicated now sometimes the jogs all work correctly but when I get to the raise bit it goes down… Am thinking this is the board or like you suggest the wiring, I will keep trying its got to be possibly something that I have done.

Many regards and keep safe.

Stuart

Hi Dave

Many thanks for replying and I apologise for the delay

The jogs all work as they should but when using the raise bed button some or most of the time the Z axis moves down

Am now thinking its the board that faulty.

Will try changing the board and or checking all copnnections

Many thanks and stay safe.

Stuart

Hey Stuart, just saw your message.

What Gcode sender software are you using? I’m not aware of a “raise bed” button in Easel (although to be fair, it’s been over a year since I’ve used Easel).

Strictly speaking, if you were to “raise the bed”, you’d be moving it closer to the tool head, so if the bit moves down it’s achieving the same thing.

1 Like

That was my mistake I meant bit.

I home the bit onto the top of the material etc and then when I hit the Raise The Bit button The Z axis moves all the way to the top and then when I start the carve it only comes back down partway usually starts working about 1" short of the surface of the material I am using. It did work correctly once some weeks ago then the following day when i went to use it again thats when this started.

I have used a second piece of wood on top of the bottom one when the bit has raised up slightly and then the image that it cuts is tiny ( for instance I picked a 2" square image and when I got it to cut the image was 1/4 of an inch square).

It must be something I have done. I have changed the control board. I have tried different cables I have used two different laptops and a PC and all give the same result.

I am a simple bloke me I buy something and expect it to work but hey ho thats life>

Many regards and stay safe.

Stuart

Have you run Machine Setup in Easel on your machine? That could have inadvertently overwritten some GRBL configuration vales that are now causing this errant behavior.

Hi Dave

Yes I think I have set up the machine many times.

Yesterday I brought the CNC ( only small) machine into the house and got everything to appear to work normally apart from the size of the image that is. Then when I tried it in my workshop everything went smooth and the jogs worked ( Zaxis one going in the right direction) then preparing to carve when I hit the Raise bit key the z axis came down not up . I am thinking that there i/s some kind of wiring fault i/n the connection although I have tried diffent USB cables.

Many regards And stay safe.

Stuart

If one of the 4 wires for the steppers dont have contact, it will run as normal but direction will be lost.
So if one stepper only move in one direction when jogged either way one of its wires are broken.

It wouldn’t be a fault in the USB cable. If there’s any problem in that connection, the machine simply won’t respond (instructions sent over the USB connection can’t be “misinterpreted”).

I’m with @HaldorLonningdal - I think you’ve got an intermittent wiring problem between the controller and your stepper motors. Aside from that, there might be something wrong with the controller itself.

Go Here and watch this may help you get on your way

There can be based on the machine design (not then carve obviously), but if you did a corexy setup then the head would do only x-y movement and the bed would go up and down when you jog z. Most milling machines don’t do this, but some of the rally fancy 5+axis machines have crazy moving beds. But yeah, he meant the z-axis…