Z axis flashing

I was using the Universe G-code sender and hit the return to zero when I was trying to set the current location as zero. It first tried to push the bit into the waste board but then stopped within a few seconds and then raised the bit and moved to the center of work area.

After that it started sounding like it was moving one step at a time and the Z- axis just flashes as it does this(fast rate). It does not actual move the Z motor at all. It also seems to be in a cycle. after a short while it sounds almost like it is trying to make one big move then starts again. If I send a command to the Z motor to either raise or lower you will see the motor try to move but just does not have enough power to do so. The other axis all work fine.

I have hit the rest on the G-shield and everything stops for a second but then starts right up again. have powered down the whole system and rebooted the laptop and as soon as the laptop powers back up and provides power to the Arduino the same thing starts to happen again.

The console just shows the following over and over again.


I am not sure how to get it to stop what it is doing and start operating again. any help would be great.

UCGS uses the G28 command when you press the “Return to Zero” button. Have you set the G28.1 position?

If you don’t know what this is search for G28 to find threads that talk about it.

Thanks for the quick reply. I had not used G28 before. I just read a few posts about it after reading your message and tried to set G28.1 however I am still have the same issues

Post your $$ output from grbl here.

$0=10 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=3 (dir port invert mask:00000011)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=3 (homing dir invert mask:00000011)
$24=25.000 (homing feed, mm/min)
$25=750.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.000 (x, step/mm)
$101=40.000 (y, step/mm)
$102=188.976 (z, step/mm)
$110=8000.000 (x max rate, mm/min)
$111=8000.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=500.000 (x accel, mm/sec^2)
$121=500.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=290.000 (x max travel, mm)
$131=290.000 (y max travel, mm)
$132=100.000 (z max travel, mm)

Your configuration is reasonable. You don’t use homing?

Actually I just finished my X-Carve tonight and I did the test carve in Easel without issue. I then wanted to try and test out a design I made in Fusion360 while I was was waitting for the X-Carve to arrive. I was trying to figure out how to zero everything so when I was ready to import my file it would be ready to go an this happened, so everything is still very new to me.

Ok. Since you are new to this, my guess is that you have a problem with your toolpath.

Without using homing, Machine Zero is where the spindle is when you power up the machine.

You can jog to a different position and then set Work Zero with the “Reset Zero” button in UGCS.

This defines the X and Y position that corresponds to the origin in your design. You then have to adjust the Z Zero position to correspond with the point you selected in your design.

Thanks for that piece of info. That will help once I get it past this. Currently I was just using UGS on its own so there is no tool path at all.

One other thing that seems strange is that when I do hit reset zero I get “Error Unsupported command”

Did you download and install Java, or was it already on your machine? If you don’t have the latest version download and install it and see if that helps.

Which version of UGCS are you using?

I am using 1.0.7. I did have an older Java version and just updated Java to the newest version. I still get unsupported command if I hit the reset zero.

Another item to bring up. Before I hit the return to zero, everything was working fine in UGS. In fact I used it to set what I wanted to use as my zero point. So it seems it is running something, just not sure what it is doing at this point.

I am wondering if I reflash the Arduino would help. I found a few threads that show a download location for the image that should be on it. I have worked with Arduino’s in the past had have written some of my own sketches so I assume it is just needing to load the sketch with the original image. I would hate to have to go that route just in case something else goes wrong with the image.

I’m using UGCS version 1.0.9 I think your version should be ok for the testing you are doing.

Use the .hex file included in this .zip file

ugcs messes up a lot on rezeroing. sometimes it works, sometimes it goes plus z until it it crashes at the top and sometimes it drives the bit into the wasteboard.

I don’t trust it anymore to re zero.


What version of UGCS were you running and what do you mean by re-zero? What is the command or button you are using to “re-zero”?